By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
443,626 Members | 2,202 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 443,626 IT Pros & Developers. It's quick & easy.

installed PHP and now Apache won't start

P: n/a
I installed Apache 2.2.3 per the instructions in the book I'm reading
'AJAX and PHP' by Darie et al. After installation, I confirmed that the
server was working. I then installed MySQL and PHP. After configuring
the system per the book's instructions, I now find that the Apache
server won't start.

How do I start to troubleshoot this problem? I haven't a clue at this
point. Any help would be greatly appreciated.

TIA,
David

Oct 18 '06 #1
Share this Question
Share on Google+
9 Replies


P: n/a
BTW, I'm on Windows XP.
===============================

da******@gmail.com wrote:
I installed Apache 2.2.3 per the instructions in the book I'm reading
'AJAX and PHP' by Darie et al. After installation, I confirmed that the
server was working. I then installed MySQL and PHP. After configuring
the system per the book's instructions, I now find that the Apache
server won't start.

How do I start to troubleshoot this problem? I haven't a clue at this
point. Any help would be greatly appreciated.

TIA,
David
Oct 18 '06 #2

P: n/a
da******@gmail.com wrote:
I installed Apache 2.2.3 per the instructions in the book I'm reading
'AJAX and PHP' by Darie et al. After installation, I confirmed that the
server was working. I then installed MySQL and PHP. After configuring
the system per the book's instructions, I now find that the Apache
server won't start.

How do I start to troubleshoot this problem? I haven't a clue at this
point. Any help would be greatly appreciated.

TIA,
David

What's in the Apache error log (apache/logs/error.log)?

--
*****************************
Chuck Anderson Boulder, CO
http://www.CycleTourist.com
*****************************
Oct 18 '06 #3

P: n/a
da******@gmail.com wrote in news:1161214995.087958.318360
@k70g2000cwa.googlegroups.com:
I installed Apache 2.2.3 per the instructions in the book I'm reading
'AJAX and PHP' by Darie et al. After installation, I confirmed that the
server was working. I then installed MySQL and PHP. After configuring
the system per the book's instructions, I now find that the Apache
server won't start.

How do I start to troubleshoot this problem? I haven't a clue at this
point. Any help would be greatly appreciated.

TIA,
David

I had the same problem the other day. I had PHP 5 and Apache 2.0
installed and upgraded to Apache 2.2.3 and it didn't work.

The problem is with Apache; they changed their API and that broke PHP,
at least on Windows XP.

Solution:

Go to http://snaps.php.net and download the latest PHP development
snapshot. It is stable (or so they say), but isn't the normal download.
Inside is a different version of the PHP dll needed to link PHP to
Apache. It is now php5apache2_2.dll.

1) Make sure php5ts.dll is in the Apache\bin folder
2) You MAY (or may not--I did) need to add the following line to Apache's
httpd.config file: Win32DisableAcceptEx (Apache runs at 100% CPU without
it on my system).
3) Make sure you set up your php.ini file per PHP's install.txt
instructions
4) Add the following lines to httpd.config (per PHP install.txt
instructions):

LoadModule php5_module "C:/directoryPHPIsIn/php5apache2_2.dll"
AddType application/x-httpd-php .php
PHPIniDir "C:/directoryPHPIsIn/"
AddType application/x-httpd-php-source .phps

That SHOULD get it to work. If not, let me know.
Oct 19 '06 #4

P: n/a
Still getting an error. Told that it can't find php5apache2.dll
specified in httpd.conf as follows (PHP stored in c:\php\):

LoadModule php5_module "c:/php/php5apache2.dll"
AddType application/x-httpd-php .php
PHPIniDir "C:/php/"
AddType application/x-httpd-php-source .phps

Yet I've confirmed it's there (along with the new php5apache2_2.dll).

Also, I should move php5ts.dll from windows/system32, right?

Thanks for your help!
David

Go to http://snaps.php.net and download the latest PHP development
snapshot. It is stable (or so they say), but isn't the normal download.
Inside is a different version of the PHP dll needed to link PHP to
Apache. It is now php5apache2_2.dll.

1) Make sure php5ts.dll is in the Apache\bin folder
2) You MAY (or may not--I did) need to add the following line to Apache's
httpd.config file: Win32DisableAcceptEx (Apache runs at 100% CPU without
it on my system).
3) Make sure you set up your php.ini file per PHP's install.txt
instructions
4) Add the following lines to httpd.config (per PHP install.txt
instructions):

LoadModule php5_module "C:/directoryPHPIsIn/php5apache2_2.dll"
AddType application/x-httpd-php .php
PHPIniDir "C:/directoryPHPIsIn/"
AddType application/x-httpd-php-source .phps

That SHOULD get it to work. If not, let me know.
Oct 19 '06 #5

P: n/a
sigh...

The same issues, over and over and over.

If you want a real solid install of Apache and PHP (with Perl, SSH,
mySQL, etc) then please take a look at...

web.torres.ws/walters_way

This outlines complete instructions to install all this stuff witout a
single file in the WINDOWS directory nor a key in the registry (I don't
cound ENV VARS, even though that's where their kept).

The first install takes a bit of time, about 20 minutes. But when your
done, you will know how things work nd how they go together. Back up is
a simple burn to a CD, and the restore is a simple copy from that CD
and reinsert the ENV VARS.

I hope to add SVN to the list soon.

Please take a look at my instructions. They may help you.

Walter

Oct 19 '06 #6

P: n/a
da******@gmail.com wrote:
I installed Apache 2.2.3 per the instructions in the book I'm reading
'AJAX and PHP' by Darie et al. After installation, I confirmed that the
server was working. I then installed MySQL and PHP. After configuring
the system per the book's instructions, I now find that the Apache
server won't start.

How do I start to troubleshoot this problem? I haven't a clue at this
point. Any help would be greatly appreciated.

TIA,
David
The folks on alt.apache.configuration will be a lot more help.

--
==================
Remove the "x" from my email address
Jerry Stuckle
JDS Computer Training Corp.
js*******@attglobal.net
==================
Oct 19 '06 #7

P: n/a
da******@gmail.com wrote in
news:11**********************@m73g2000cwd.googlegr oups.com:
Still getting an error. Told that it can't find php5apache2.dll
specified in httpd.conf as follows (PHP stored in c:\php\):

LoadModule php5_module "c:/php/php5apache2.dll"
AddType application/x-httpd-php .php
PHPIniDir "C:/php/"
AddType application/x-httpd-php-source .phps

Yet I've confirmed it's there (along with the new php5apache2_2.dll).

Also, I should move php5ts.dll from windows/system32, right?

Thanks for your help!
David
You need php5apache2_2.dll. php5apache2.dll is irrelevant as it will not
work.

Did you make sure that php5ts.dll and php_mysql.dll files were copied to
Apache2.2/bin directory?

Also, if you have firewall software, make sure that the programs aren't
blocked.

That's all I can think of...that's how I got it to work.

Otherwise you'll have to downgrade to a lower Apache version.

>
>Go to http://snaps.php.net and download the latest PHP development
snapshot. It is stable (or so they say), but isn't the normal
download. Inside is a different version of the PHP dll needed to link
PHP to Apache. It is now php5apache2_2.dll.

1) Make sure php5ts.dll is in the Apache\bin folder
2) You MAY (or may not--I did) need to add the following line to
Apache's httpd.config file: Win32DisableAcceptEx (Apache runs at
100% CPU without it on my system).
3) Make sure you set up your php.ini file per PHP's install.txt
instructions
4) Add the following lines to httpd.config (per PHP install.txt
instructions):

LoadModule php5_module "C:/directoryPHPIsIn/php5apache2_2.dll"
AddType application/x-httpd-php .php
PHPIniDir "C:/directoryPHPIsIn/"
AddType application/x-httpd-php-source .phps

That SHOULD get it to work. If not, let me know.
Oct 19 '06 #8

P: n/a
I hadn't seen any instrcution re php_mysql.dll. Copied it as you
suggested and now it works!!

Thanks so much!

Lone Clapper wrote:
da******@gmail.com wrote in
news:11**********************@m73g2000cwd.googlegr oups.com:
Still getting an error. Told that it can't find php5apache2.dll
specified in httpd.conf as follows (PHP stored in c:\php\):

LoadModule php5_module "c:/php/php5apache2.dll"
AddType application/x-httpd-php .php
PHPIniDir "C:/php/"
AddType application/x-httpd-php-source .phps

Yet I've confirmed it's there (along with the new php5apache2_2.dll).

Also, I should move php5ts.dll from windows/system32, right?

Thanks for your help!
David

You need php5apache2_2.dll. php5apache2.dll is irrelevant as it will not
work.

Did you make sure that php5ts.dll and php_mysql.dll files were copied to
Apache2.2/bin directory?

Also, if you have firewall software, make sure that the programs aren't
blocked.

That's all I can think of...that's how I got it to work.

Otherwise you'll have to downgrade to a lower Apache version.


Go to http://snaps.php.net and download the latest PHP development
snapshot. It is stable (or so they say), but isn't the normal
download. Inside is a different version of the PHP dll needed to link
PHP to Apache. It is now php5apache2_2.dll.

1) Make sure php5ts.dll is in the Apache\bin folder
2) You MAY (or may not--I did) need to add the following line to
Apache's httpd.config file: Win32DisableAcceptEx (Apache runs at
100% CPU without it on my system).
3) Make sure you set up your php.ini file per PHP's install.txt
instructions
4) Add the following lines to httpd.config (per PHP install.txt
instructions):

LoadModule php5_module "C:/directoryPHPIsIn/php5apache2_2.dll"
AddType application/x-httpd-php .php
PHPIniDir "C:/directoryPHPIsIn/"
AddType application/x-httpd-php-source .phps

That SHOULD get it to work. If not, let me know.
Oct 19 '06 #9

P: n/a
da******@gmail.com wrote in
news:11*********************@k70g2000cwa.googlegro ups.com:
I hadn't seen any instrcution re php_mysql.dll. Copied it as you
suggested and now it works!!
The PHP instructions are poorly written.

Basically, what the instructions say is that to use an extension you must
put the DLL file in a directory where PHP can find it. Then it offers
suggestions like the Windows system folder (\Windows or \Windows
\System32) or in the Apache\bin folder.

Glad you got it working.
>
Thanks so much!

Lone Clapper wrote:
>da******@gmail.com wrote in
news:11**********************@m73g2000cwd.googleg roups.com:
Still getting an error. Told that it can't find php5apache2.dll
specified in httpd.conf as follows (PHP stored in c:\php\):

LoadModule php5_module "c:/php/php5apache2.dll"
AddType application/x-httpd-php .php
PHPIniDir "C:/php/"
AddType application/x-httpd-php-source .phps

Yet I've confirmed it's there (along with the new
php5apache2_2.dll).

Also, I should move php5ts.dll from windows/system32, right?

Thanks for your help!
David

You need php5apache2_2.dll. php5apache2.dll is irrelevant as it will
not work.

Did you make sure that php5ts.dll and php_mysql.dll files were copied
to Apache2.2/bin directory?

Also, if you have firewall software, make sure that the programs
aren't blocked.

That's all I can think of...that's how I got it to work.

Otherwise you'll have to downgrade to a lower Apache version.

>

Go to http://snaps.php.net and download the latest PHP development
snapshot. It is stable (or so they say), but isn't the normal
download. Inside is a different version of the PHP dll needed to
link PHP to Apache. It is now php5apache2_2.dll.

1) Make sure php5ts.dll is in the Apache\bin folder
2) You MAY (or may not--I did) need to add the following line to
Apache's httpd.config file: Win32DisableAcceptEx (Apache runs at
100% CPU without it on my system).
3) Make sure you set up your php.ini file per PHP's install.txt
instructions
4) Add the following lines to httpd.config (per PHP install.txt
instructions):

LoadModule php5_module "C:/directoryPHPIsIn/php5apache2_2.dll"
AddType application/x-httpd-php .php
PHPIniDir "C:/directoryPHPIsIn/"
AddType application/x-httpd-php-source .phps

That SHOULD get it to work. If not, let me know.

Oct 20 '06 #10

This discussion thread is closed

Replies have been disabled for this discussion.