By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,686 Members | 1,603 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,686 IT Pros & Developers. It's quick & easy.

installing dynamic extension: http

P: n/a
I am unable to get my downloaded extension from pecl to link up with
php
properly. seems like the php.so
I could not use pear install http. pear claimed the extension was
already
installed. that is certainly not true.

I downloaded the http extension from pecl.

cvs -d:pserver:cv*****@cvs.php.net:/repository co pecl/http

I did a phpize,
and configure. my zlibrary is old, so I said skip it.

../configure --without-http-zlib-compression

did a make - everthing compiled okay.

then I did a make install:
(actually sudo make install)
executing bashrc file
executing bashrc file
Installing shared extensions:
/usr/local/lib/php/extensions/no-debug-non-zts-20050922/
executing bashrc file
executing bashrc file
executing bashrc file
Installing header files: /usr/local/include/php/

then I tried make test
and got this:

libdev: make test
/bin/bash /users/es287/develop/pecl/pecl/http/libtool --mode=install cp
../http.la /users/es287/develop/pecl/pecl/http/modules
executing bashrc file
cp ./.libs/http.so /users/es287/develop/pecl/pecl/http/modules/http.so
chmod +x /users/es287/develop/pecl/pecl/http/modules/http.so
cp ./.libs/http.lai /users/es287/develop/pecl/pecl/http/modules/http.la
----------------------------------------------------------------------
Libraries have been installed in:
/users/es287/develop/pecl/pecl/http/modules

If you ever happen to want to link against installed libraries
in a given directory, LIBDIR, you must either use libtool, and
specify the full pathname of the library, or use the `-LLIBDIR'
flag during linking and do at least one of the following:
- add LIBDIR to the `LD_LIBRARY_PATH' environment variable
during execution
- use the `-RLIBDIR' linker flag

See any operating system documentation about shared libraries for
more information, such as the ld(1) and ld.so(8) manual pages.
----------------------------------------------------------------------
executing bashrc file

executing bashrc file
Build complete.
executing bashrc file
(It is safe to ignore warnings about tempnam and tmpnam).
executing bashrc file

executing bashrc file

Warning: Unknown: Unable to load dynamic library 'modules/http.so' -
ld.so.1: /usr/local/bin/php: fatal: relocation error: file
modules/http.so: symbol OnUpdateBool: referenced symbol not found in
Unknown on line 0

Warning: Unknown: Unable to load dynamic library 'modules/http.so' -
ld.so.1: /usr/local/bin/php: fatal: relocation error: file
modules/http.so: symbol OnUpdateBool: referenced symbol not found in
Unknown on line 0

================================================== ===================
CWD : /develop/es287/pecl/pecl/http
PHP : /usr/local/bin/php
PHP_SAPI : cli
PHP_VERSION : 5.1.4
ZEND_VERSION: 2.1.0
PHP_OS : SunOS - SunOS libdev 5.8 Generic_108528-23 sun4u
INI actual : /usr/local/lib/php.ini
More .INIs :
Extra dirs :
================================================== ===================
Running selected tests.
SKIP HttpMessage [tests/HttpMessage_001.phpt] reason: need ext/http
all the tests are skipped. Because the extension did not load
properly,
I assume.
Thanks a lot,
zippy

Sep 12 '06 #1
Share this Question
Share on Google+
1 Reply


P: n/a
sorry that my thinking did not match my writing very clearly.
I was trying to say, that there is some problem linking the php.so
that is loaded into apache, and the http.so file.
I don't actually know what happens in the apache environment - I have
not gotten any further than testing from the command line, as shown
below.

Zippy
zpinhead wrote:
I am unable to get my downloaded extension from pecl to link up with
php
properly. seems like the php.so
I could not use pear install http. pear claimed the extension was
already
installed. that is certainly not true.

I downloaded the http extension from pecl.

cvs -d:pserver:cv*****@cvs.php.net:/repository co pecl/http

I did a phpize,
and configure. my zlibrary is old, so I said skip it.

./configure --without-http-zlib-compression

did a make - everthing compiled okay.

then I did a make install:
(actually sudo make install)
executing bashrc file
executing bashrc file
Installing shared extensions:
/usr/local/lib/php/extensions/no-debug-non-zts-20050922/
executing bashrc file
executing bashrc file
executing bashrc file
Installing header files: /usr/local/include/php/

then I tried make test
and got this:

libdev: make test
/bin/bash /users/es287/develop/pecl/pecl/http/libtool --mode=install cp
./http.la /users/es287/develop/pecl/pecl/http/modules
executing bashrc file
cp ./.libs/http.so /users/es287/develop/pecl/pecl/http/modules/http.so
chmod +x /users/es287/develop/pecl/pecl/http/modules/http.so
cp ./.libs/http.lai /users/es287/develop/pecl/pecl/http/modules/http.la
----------------------------------------------------------------------
Libraries have been installed in:
/users/es287/develop/pecl/pecl/http/modules

If you ever happen to want to link against installed libraries
in a given directory, LIBDIR, you must either use libtool, and
specify the full pathname of the library, or use the `-LLIBDIR'
flag during linking and do at least one of the following:
- add LIBDIR to the `LD_LIBRARY_PATH' environment variable
during execution
- use the `-RLIBDIR' linker flag

See any operating system documentation about shared libraries for
more information, such as the ld(1) and ld.so(8) manual pages.
----------------------------------------------------------------------
executing bashrc file

executing bashrc file
Build complete.
executing bashrc file
(It is safe to ignore warnings about tempnam and tmpnam).
executing bashrc file

executing bashrc file

Warning: Unknown: Unable to load dynamic library 'modules/http.so' -
ld.so.1: /usr/local/bin/php: fatal: relocation error: file
modules/http.so: symbol OnUpdateBool: referenced symbol not found in
Unknown on line 0

Warning: Unknown: Unable to load dynamic library 'modules/http.so' -
ld.so.1: /usr/local/bin/php: fatal: relocation error: file
modules/http.so: symbol OnUpdateBool: referenced symbol not found in
Unknown on line 0

================================================== ===================
CWD : /develop/es287/pecl/pecl/http
PHP : /usr/local/bin/php
PHP_SAPI : cli
PHP_VERSION : 5.1.4
ZEND_VERSION: 2.1.0
PHP_OS : SunOS - SunOS libdev 5.8 Generic_108528-23 sun4u
INI actual : /usr/local/lib/php.ini
More .INIs :
Extra dirs :
================================================== ===================
Running selected tests.
SKIP HttpMessage [tests/HttpMessage_001.phpt] reason: need ext/http
all the tests are skipped. Because the extension did not load
properly,
I assume.
Thanks a lot,
zippy
Sep 12 '06 #2

This discussion thread is closed

Replies have been disabled for this discussion.