By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
455,748 Members | 1,427 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 455,748 IT Pros & Developers. It's quick & easy.

405 Post Method not allowed

P: n/a
I've searched the web for a solution but to no avail. I have just setup and
installed Apache 1.3.20 on windows, and php 4.0.5. Apache is up and
running, (In directory F:\programs\apache\apache\) and PHP has been copied
to both c:\php and F:\programs\apache\apache\php. I've put the php.ini file
in c:\windows and made the following changes:
doc_root = "f:\programs\apache\apache\htdocs"
extension_dir = "c:\php"

While in httpd I have added:
ScriptAlias /php/ "C:/php/"

(uncommented) AddType application/x-httpd-php .php

Action application/x-http-php "/php/php.exe"

Anytime I try to load a php script I get a 405 error stating that:

The requested method POST is not allowed for the URL /password.php.

Any help would be much appreciated. I know it is something simple, because
I've set it up on other computers. But on my home XP machine, I have never
had any success.
Jul 17 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
On Sun, 04 Apr 2004 19:30:43 GMT, "Tim yOUNG" <ti********@yahoo.com> wrote:
I've searched the web for a solution but to no avail. I have just setup and
installed Apache 1.3.20
Old version...
on windows,
1.3 isn't recommended on Windows...
and php 4.0.5.
Very ancient version...
Apache is up and
running, (In directory F:\programs\apache\apache\) and PHP has been copied
to both c:\php and F:\programs\apache\apache\php. I've put the php.ini file
in c:\windows and made the following changes:
doc_root = "f:\programs\apache\apache\htdocs"
extension_dir = "c:\php"
Not c:\php\extensions?
While in httpd I have added:
ScriptAlias /php/ "C:/php/"
You don't want to be making the PHP directory accessible, you should put your
scripts somewhere else.
(uncommented) AddType application/x-httpd-php .php

Action application/x-http-php "/php/php.exe"
No drive letter?

You've got 'application/x-httpd-php' in the first line, but
'application-x-http/php' in the second?
Anytime I try to load a php script I get a 405 error stating that:

The requested method POST is not allowed for the URL /password.php.


Do you have a <Directory> entry in httpd.conf for the directory?

--
Andy Hassall <an**@andyh.co.uk> / Space: disk usage analysis tool
http://www.andyh.co.uk / http://www.andyhsoftware.co.uk/space
Jul 17 '05 #2

P: n/a
Hey Andy, thanks for the tips.

I've downloaded the latest Apache 2.0.49 and then tried the new php5 in
module mode.

Now it will run the php files, but wont read form data and will spit out any
error message asociated with not filling in an input box properly.

I've decided to try php 4.3.5 as it's supposed to be the most stable.

I'll keep you updated. 0 ?
\ __/

"Andy Hassall" <an**@andyh.co.uk> wrote in message
news:nv********************************@4ax.com...
On Sun, 04 Apr 2004 19:30:43 GMT, "Tim yOUNG" <ti********@yahoo.com> wrote:
I've searched the web for a solution but to no avail. I have just setup andinstalled Apache 1.3.20
Old version...
on windows,


1.3 isn't recommended on Windows...
and php 4.0.5.


Very ancient version...
Apache is up and
running, (In directory F:\programs\apache\apache\) and PHP has been copiedto both c:\php and F:\programs\apache\apache\php. I've put the php.ini filein c:\windows and made the following changes:
doc_root = "f:\programs\apache\apache\htdocs"
extension_dir = "c:\php"


Not c:\php\extensions?
While in httpd I have added:
ScriptAlias /php/ "C:/php/"


You don't want to be making the PHP directory accessible, you should put

your scripts somewhere else.
(uncommented) AddType application/x-httpd-php .php

Action application/x-http-php "/php/php.exe"


No drive letter?

You've got 'application/x-httpd-php' in the first line, but
'application-x-http/php' in the second?
Anytime I try to load a php script I get a 405 error stating that:

The requested method POST is not allowed for the URL /password.php.


Do you have a <Directory> entry in httpd.conf for the directory?

--
Andy Hassall <an**@andyh.co.uk> / Space: disk usage analysis tool
http://www.andyh.co.uk / http://www.andyhsoftware.co.uk/space

Jul 17 '05 #3

P: n/a
OK, I've got it now.

The newer versions of php default to having "register_globals = Off" and my
php files had been written as if they were turned on.

Simple solution, change globals back to on. Better solution, start writing
and re-writing code allowing for globals to be off.

Cheers!
register_globals = Off
Jul 17 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.