By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
455,822 Members | 1,433 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 455,822 IT Pros & Developers. It's quick & easy.

An urgent problem!! " Allowed memory size of 8388608 bytes exhausted ..."

P: n/a
Joe
Hi,

Now I am using Red Hat Linux 8.0 + squirrelmail as mail server. One
day, I got the following warning:

Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to
allocate 35 bytes) in
/usr/share/squirrelmail/functions/imap_messages.php
on line 325

I've been searching for the solution for quite a while, but still can
not find it. Someone told me it's bug of PHP, someone said I could
change the memory_limit in php.ini to a bigger value, say 20-30M.

Who know which one is the correct one? Also, if I change memory_limit,
how can I make it effective? or how to re-run php?

Thanks!!
Jul 17 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Joe wrote:
Hi,

Now I am using Red Hat Linux 8.0 + squirrelmail as mail server. One
day, I got the following warning:

Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to
allocate 35 bytes) in
/usr/share/squirrelmail/functions/imap_messages.php
on line 325

I've been searching for the solution for quite a while, but still can
not find it. Someone told me it's bug of PHP, someone said I could
change the memory_limit in php.ini to a bigger value, say 20-30M.

Who know which one is the correct one?
Hi,

I know the second is correct.
I don't know of any bug in PHP concerning imap_messages. Did you search the
bugparade? Or ask the person in question where he/she did get this piece of
wisdom?

Also, if I change memory_limit,
how can I make it effective? or how to re-run php?
php.ini will be reevaluated if you restart apache
(as root)
/usr/sbin/apachectl --gracefull

hope that helps.

Regards,
Erwin Moller

Thanks!!


Jul 17 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.