By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
429,066 Members | 1,841 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 429,066 IT Pros & Developers. It's quick & easy.

connection to database

P: 31
hi there...

i'm quite new in PHP...
i have create a program using PHP 4.3 and MySQL 4.1... the problem is when i want to connect the code to the database, there is an error:

Warning: mysql_connect(): Client does not support authentication protocol requested by server; consider upgrading MySQL client in... ..

Can i know why?
I have using two MySQL with different version (MySQL 4.1 and MySQL 5.0) in different port..
Jul 17 '06 #1
Share this Question
Share on Google+
1 Reply


ronverdonk
Expert 2.5K+
P: 4,258
Best I can do is point you to the MySQL documentation at www.MySQL.com with the following link http://dev.mysql.com/doc/refman/4.1/en/old-client.html
That is a chapter called A.2.3. Client does not support authentication protocol, exactly what you are looking for.

Good luck - Ronald :cool:
Jul 19 '06 #2

Post your reply

Sign in to post your reply or Sign up for a free account.