By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
428,853 Members | 2,144 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 428,853 IT Pros & Developers. It's quick & easy.

$cfg['Lang'] in phpMyAdmin config

P: n/a

I am trying to configure phpMyAdmin 2.8.2. I un-commented the following
line in

// Force: always use this language - must be defined in
// libraries/select_lang.lib.php
$cfg['Lang'] = 'en-iso-8859-1';

but then after logging into phpMyAdmin, I get an error message:

Notice: Undefined index: en-iso-8859-1 in ...\index.php on line 97

I went into index.php and found that this is the line in question:

$lang_iso_code = $GLOBALS['available_languages'][$GLOBALS['lang']][2];

So I went into select_lang.lib.php as suggested in the documentation and
poked around. 'en-iso-8859-1' is definitely a key in the
$available_languages array on this page, but then by the time the above
line of code gets called on index.php, this key is missing from
$GLOBALS['available_languages']. At that point, this is the only key in
the array for English, which is why I am getting the error message:

[en-utf-8] =Array
[0] =en|english
[1] =english-utf-8
[2] =en
[3] =>

Does anyone know why this is happening, and how I can uncomment the
$cfg['Lang'] = 'en-iso-8859-1'; line and not have all these problems?
This is the only change I made that resulted in the error message; if I
again comment out the line in question as it comes defaulted, everything
works fine. Thanks for all your help.
Jul 10 '06 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.