By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
434,640 Members | 2,077 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 434,640 IT Pros & Developers. It's quick & easy.

phpize: line 57: aclocal: command not found

P: n/a
Hi.

Working with PHP 4.3.10 on Fedora Core 2.

I'm trying to execute phpize:
/usr/local/php/bin/phpize: line 57: aclocal: command not found

I've just installed:
automake17-1.7.9-2
autoconf-2.59-3
by using RPMs.

And if I try to find 'aclocal':
[]# locate aclocal
/lib/modules/2.6.5-1.358/build/include/acpi/aclocal.h
/lib/modules/2.6.5-1.358smp/build/include/acpi/aclocal.h
/usr/share/aclocal
/usr/share/aclocal/libmikmod.m4
/usr/share/aclocal/xsize.m4
/usr/share/aclocal/uintmax_t.m4
/usr/share/aclocal/wine.m4
/usr/share/aclocal/stdint_h.m4
/usr/share/aclocal/progtest.m4
/usr/share/aclocal/lib-prefix.m4
/usr/share/aclocal/lib-link.m4
/usr/share/aclocal/xml-i18n-tools.m4
/usr/share/aclocal/size_max.m4
/usr/share/aclocal/longlong.m4
/usr/share/aclocal/intltool.m4
/usr/share/aclocal/codeset.m4
/usr/share/aclocal/lib-ld.m4
/usr/share/aclocal/nls.m4
/usr/share/aclocal/pkg.m4
/usr/share/aclocal/intdiv0.m4
/usr/share/aclocal/ulonglong.m4
/usr/share/aclocal/wchar_t.m4
/usr/share/aclocal/wint_t.m4
/usr/share/aclocal/longdouble.m4
/usr/share/aclocal/iconv.m4
/usr/share/aclocal/intmax.m4
/usr/share/aclocal/inttypes_h.m4
/usr/share/aclocal/inttypes.m4
/usr/share/aclocal/isc-posix.m4
/usr/share/aclocal/inttypes-pri.m4
/usr/share/aclocal/gettext.m4
/usr/share/aclocal/lcmessage.m4
/usr/share/aclocal/freetype2.m4
/usr/share/aclocal/signed.m4
/usr/share/aclocal/printf-posix.m4
/usr/share/aclocal/glibc21.m4
/usr/share/aclocal/po.m4
/usr/share/aclocal
/usr/local/freetype/share/aclocal
/usr/local/freetype/share/aclocal/freetype2.m4
/usr/local/freetype/share/aclocal

What am I doing wrong?

Jul 4 '06 #1
Share this Question
Share on Google+
2 Replies


P: n/a
*** fr**********@usa.com escribió/wrote (4 Jul 2006 02:29:08 -0700):
I'm trying to execute phpize:
/usr/local/php/bin/phpize: line 57: aclocal: command not found

I've just installed:
automake17-1.7.9-2
autoconf-2.59-3
by using RPMs.
In my system (good old Red Hat 9):

/usr/bin/aclocal
a /usr/bin/perl script text executable
automake-1.6.3-5

According to http://rpmfind.net/ there seem to be two different packages:
"automake" and "automake17". The latter (the one you have installed) is an
older version of Automake "to run automake in a project that
has not yet been updated to work with latest version of Automake".
--
-+ http://alvaro.es - Álvaro G. Vicario - Burgos, Spain
++ Mi sitio sobre programación web: http://bits.demogracia.com
+- Mi web de humor con rayos UVA: http://www.demogracia.com
--
Jul 4 '06 #2

P: n/a
Hi Alvaro

Thank you very much for your answer. I installed autoconf+automake
from sources and it works.

Regards, y un abrazo.
Alvaro G. Vicario wrote:
*** fr**********@usa.com escribió/wrote (4 Jul 2006 02:29:08 -0700):
I'm trying to execute phpize:
/usr/local/php/bin/phpize: line 57: aclocal: command not found

I've just installed:
automake17-1.7.9-2
autoconf-2.59-3
by using RPMs.

In my system (good old Red Hat 9):

/usr/bin/aclocal
a /usr/bin/perl script text executable
automake-1.6.3-5

According to http://rpmfind.net/ there seem to be two different packages:
"automake" and "automake17". The latter (the one you have installed) is an
older version of Automake "to run automake in a project that
has not yet been updated to work with latest version of Automake".
--
-+ http://alvaro.es - Álvaro G. Vicario - Burgos, Spain
++ Mi sitio sobre programación web: http://bits.demogracia.com
+- Mi web de humor con rayos UVA: http://www.demogracia.com
--
Jul 4 '06 #3

This discussion thread is closed

Replies have been disabled for this discussion.