By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
434,905 Members | 1,783 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 434,905 IT Pros & Developers. It's quick & easy.

php5 installation

P: n/a
Hello everyone,

I have been trying for the past couple of days to get php5 installation on
either my laptop or my test server. I'm not having much luck with either.
I would like to get my test server running first (windows 2003 sp1), so I
will discuss what I've done there.

Downloaded the the latest version of php5
Extracted the files into a folder on the server c:\php5
Edited and saved the php.ini file to set cgi.force_redirect = 0
Copied the php.ini file to c:\windows
Added c:\php5 to environment path and restarted machine.
Added web extension for php under IIS
Added php to application extension under the home directory tab in IIS and
restarted machine.
Create phpinfo.php page in the inetpub directory under wwwroot.

That be said now when I bring up the phpinfo.php page, I don't get anything
but a white page. When I view my source code, I see the <? phpinfo(); ?>.
Not sure why I can't get this to work.

Any help would be greatly appreciated.

Thanks

A
Jul 3 '06 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Auddog schreef:
That be said now when I bring up the phpinfo.php page, I don't get anything
but a white page. When I view my source code, I see the <? phpinfo(); ?>.
Not sure why I can't get this to work.
Hi,

If it's a Windows 2003 server, it means you're running IIS 6. In IIS 6
you have to specifically allow the php extension to be run.
I don't have an IIS 6 machine at hand here, but the setting is located
somewhere at "Web Server Extensions".

P.S. If it's only for testing purposes WAMP-server might be a nice
option too. It's a simple installation package of Apache2, MySQL and
PHP5. See: http://www.wampserver.com

HTH.
Ruben.

--
http://www.phpforums.nl
Jul 3 '06 #2

P: n/a
It wasn't anything I thought it was. In my phpinfo file, I forgot the php
after the <?

Thanks for all the help.

A
"Peter van Schie" <va************@gmail.comwrote in message
news:44***********************@news.wanadoo.nl...
Auddog schreef:
>That be said now when I bring up the phpinfo.php page, I don't get
anything but a white page. When I view my source code, I see the <?
phpinfo(); ?>. Not sure why I can't get this to work.

Hi,

If it's a Windows 2003 server, it means you're running IIS 6. In IIS 6 you
have to specifically allow the php extension to be run.
I don't have an IIS 6 machine at hand here, but the setting is located
somewhere at "Web Server Extensions".

P.S. If it's only for testing purposes WAMP-server might be a nice option
too. It's a simple installation package of Apache2, MySQL and PHP5. See:
http://www.wampserver.com

HTH.
Ruben.

--
http://www.phpforums.nl

Jul 5 '06 #3

This discussion thread is closed

Replies have been disabled for this discussion.