By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,984 Members | 1,421 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,984 IT Pros & Developers. It's quick & easy.

Connect to mysql?

P: n/a
Hi!

I have a question. I have installed php and mysql on an apache-server on
windows and I can't connect to the server.

I tried to create a database (since I am trying to learn howto). My manual
said I should write this at the shell:
c:\mysql\bin>mysqladmin -u root creare mindb

I did this and got this error:
mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'root'@'localhost' (using password: NO)'

I then tried to use -p and wrote this instead:
c:\mysql\bin>mysqladmin -p -u root creare mindb

The database was created!

Then I tried to write mysql in cmd at c:\mysql\bin but I get this error:
Access denied for user 'ODBC'@'localhost' (using password: No)

Why??

I have used earlier versions of mysql and php and got it to work. In earlier
versions "my.ini" looks very different and user and password were written
there, but not anymore. Why, or is it me who have done something wrong? When
I log in to phpmyadmin I have to root-accounts there, one with
host=localhost and one the host=%.

All I want, is to make mysql work, so I can test things and to learn!

Thanks
Cassandra

My configuration
Windows XP pro

Netgear router (I have opened port 3306)

ADSL

no-ip (For my domain, www.kamrate.se)
Apache 2.2.2

The exe-files are in c:\apache2\bin

(All I did was to fill in domain=localhost, servername=localhost and my
email)
PHP 5.1.4

The exe-files are in c:\php

(I used the zip package)
httpd.conf

At the row below "#LoadModule ssl_module modules/mod_ssl.so" I wrote:

LoadModule php5_module "c:/php/php5apache2_2.dll
At the row below "AddType application/x-gzip .gz .tgz" I wrote:

AddType application/x-httpd-php .php
At the row below "DocumentRoot" I wrote:

PHPIniDir "C:/php"
At the row below "DocumentRoot" I wrote:

PHPIniDir "C:/php"
At the row "DirectoryIndex index.html" I wrote:

DirectoryIndex index.htm index.html index.php
php.ini

Changed "doc_root" to:

c:\Apache2\htdocs
Created a tmp-folder in:

c:\apache2\ and wrote the path in session.save_path:

c:\apache2\tmp
Saved php.ini in:

c:\php
I did restart apache and tested php and it worked!
Mysql 5.0.22

The exe-files are in c:\mysql\bin
Removed earlier versions of mysql, including the folder:

c:\mysql
I did choose to run "Configuration Wizard" and did choose a password for
root.
PhpMyAdmin

Installationfolder is "c:\apache2\htdocs"

I wrote host=localhost, user=root and password in config.inc.php.
php.ini

I removed the ; before "extension=php_mysql.dll"

I removed the ; before "extension=php_mbstring.dll"
At the row "extension_dir" I wrote:

extension_dir="c:\php\ext"
I copied libmysql.dll in c:\mysql\bin to:

c:\apache2\bin
I did restart apache and tested to surf to http://localhost/phpmyadmin and
it worked!


Jun 29 '06 #1
Share this Question
Share on Google+
5 Replies


P: n/a
Could you try next thing:

cd C:\Program Files\MySQL\MySQL Server 5.0\bin
mysql -h localhost -u root -p

use mindb

GRANT ALL PRIVILEGES ON *.* TO 'ODBC'@'localhost' IDENTIFIED BY 'yourpass' WITH GRANT OPTION;
news.telia.net wrote:
Hi!

I have a question. I have installed php and mysql on an apache-server on
windows and I can't connect to the server.

I tried to create a database (since I am trying to learn howto). My manual
said I should write this at the shell:
c:\mysql\bin>mysqladmin -u root creare mindb

I did this and got this error:
mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'root'@'localhost' (using password: NO)'

I then tried to use -p and wrote this instead:
c:\mysql\bin>mysqladmin -p -u root creare mindb

The database was created!

Then I tried to write mysql in cmd at c:\mysql\bin but I get this error:
Access denied for user 'ODBC'@'localhost' (using password: No)

Why??

I have used earlier versions of mysql and php and got it to work. In earlier
versions "my.ini" looks very different and user and password were written
there, but not anymore. Why, or is it me who have done something wrong? When
I log in to phpmyadmin I have to root-accounts there, one with
host=localhost and one the host=%.

All I want, is to make mysql work, so I can test things and to learn!

Thanks
Cassandra

My configuration
Windows XP pro

Netgear router (I have opened port 3306)

ADSL

no-ip (For my domain, www.kamrate.se)
Apache 2.2.2

The exe-files are in c:\apache2\bin

(All I did was to fill in domain=localhost, servername=localhost and my
email)
PHP 5.1.4

The exe-files are in c:\php

(I used the zip package)
httpd.conf

At the row below "#LoadModule ssl_module modules/mod_ssl.so" I wrote:

LoadModule php5_module "c:/php/php5apache2_2.dll
At the row below "AddType application/x-gzip .gz .tgz" I wrote:

AddType application/x-httpd-php .php
At the row below "DocumentRoot" I wrote:

PHPIniDir "C:/php"
At the row below "DocumentRoot" I wrote:

PHPIniDir "C:/php"
At the row "DirectoryIndex index.html" I wrote:

DirectoryIndex index.htm index.html index.php
php.ini

Changed "doc_root" to:

c:\Apache2\htdocs
Created a tmp-folder in:

c:\apache2\ and wrote the path in session.save_path:

c:\apache2\tmp
Saved php.ini in:

c:\php
I did restart apache and tested php and it worked!
Mysql 5.0.22

The exe-files are in c:\mysql\bin
Removed earlier versions of mysql, including the folder:

c:\mysql
I did choose to run "Configuration Wizard" and did choose a password for
root.
PhpMyAdmin

Installationfolder is "c:\apache2\htdocs"

I wrote host=localhost, user=root and password in config.inc.php.
php.ini

I removed the ; before "extension=php_mysql.dll"

I removed the ; before "extension=php_mbstring.dll"
At the row "extension_dir" I wrote:

extension_dir="c:\php\ext"
I copied libmysql.dll in c:\mysql\bin to:

c:\apache2\bin
I did restart apache and tested to surf to http://localhost/phpmyadmin and
it worked!


Jun 29 '06 #2

P: n/a
I tried it and it worked. What does -h mean?

I have 2 (4) users for mysql and it is "root" (local and %) with a passord
and "cassandra" (local and %) without a password, that I did create a while
ago because someone did explain that I should do that. What is the
difference between these 2 users, root and cassandra? Which user should I
use and why? Should I have both users and should "cassandra" have a
password?

I tried to us DBDesigner 4 and I get error when I try to connect to a
database with "root" but not when I use "cassandra". Why?

Thanks


cd C:\Program Files\MySQL\MySQL Server 5.0\bin
mysql -h localhost -u root -p

use mindb

GRANT ALL PRIVILEGES ON *.* TO 'ODBC'@'localhost' IDENTIFIED BY 'yourpass' WITH GRANT OPTION;

news.telia.net wrote:
Hi!

I have a question. I have installed php and mysql on an apache-server on
windows and I can't connect to the server.

I tried to create a database (since I am trying to learn howto). My manual said I should write this at the shell:
c:\mysql\bin>mysqladmin -u root creare mindb

I did this and got this error:
mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'root'@'localhost' (using password: NO)'

I then tried to use -p and wrote this instead:
c:\mysql\bin>mysqladmin -p -u root creare mindb

The database was created!

Then I tried to write mysql in cmd at c:\mysql\bin but I get this error:
Access denied for user 'ODBC'@'localhost' (using password: No)

Why??

I have used earlier versions of mysql and php and got it to work. In earlier versions "my.ini" looks very different and user and password were written there, but not anymore. Why, or is it me who have done something wrong? When I log in to phpmyadmin I have to root-accounts there, one with
host=localhost and one the host=%.

All I want, is to make mysql work, so I can test things and to learn!

Thanks
Cassandra

My configuration
Windows XP pro

Netgear router (I have opened port 3306)

ADSL

no-ip (For my domain, www.kamrate.se)
Apache 2.2.2

The exe-files are in c:\apache2\bin

(All I did was to fill in domain=localhost, servername=localhost and my
email)
PHP 5.1.4

The exe-files are in c:\php

(I used the zip package)
httpd.conf

At the row below "#LoadModule ssl_module modules/mod_ssl.so" I wrote:

LoadModule php5_module "c:/php/php5apache2_2.dll
At the row below "AddType application/x-gzip .gz .tgz" I wrote:

AddType application/x-httpd-php .php
At the row below "DocumentRoot" I wrote:

PHPIniDir "C:/php"
At the row below "DocumentRoot" I wrote:

PHPIniDir "C:/php"
At the row "DirectoryIndex index.html" I wrote:

DirectoryIndex index.htm index.html index.php
php.ini

Changed "doc_root" to:

c:\Apache2\htdocs
Created a tmp-folder in:

c:\apache2\ and wrote the path in session.save_path:

c:\apache2\tmp
Saved php.ini in:

c:\php
I did restart apache and tested php and it worked!
Mysql 5.0.22

The exe-files are in c:\mysql\bin
Removed earlier versions of mysql, including the folder:

c:\mysql
I did choose to run "Configuration Wizard" and did choose a password for
root.
PhpMyAdmin

Installationfolder is "c:\apache2\htdocs"

I wrote host=localhost, user=root and password in config.inc.php.
php.ini

I removed the ; before "extension=php_mysql.dll"

I removed the ; before "extension=php_mbstring.dll"
At the row "extension_dir" I wrote:

extension_dir="c:\php\ext"
I copied libmysql.dll in c:\mysql\bin to:

c:\apache2\bin
I did restart apache and tested to surf to http://localhost/phpmyadmin and it worked!


Jun 29 '06 #3

P: n/a
news.telia.net wrote:
Hi!

I have a question. I have installed php and mysql on an apache-server on
windows and I can't connect to the server.

I tried to create a database (since I am trying to learn howto). My manual
said I should write this at the shell:
c:\mysql\bin>mysqladmin -u root creare mindb

I did this and got this error:
mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'root'@'localhost' (using password: NO)'

I then tried to use -p and wrote this instead:
c:\mysql\bin>mysqladmin -p -u root creare mindb

The database was created!

Then I tried to write mysql in cmd at c:\mysql\bin but I get this error:
Access denied for user 'ODBC'@'localhost' (using password: No)

Why??

I have used earlier versions of mysql and php and got it to work. In earlier
versions "my.ini" looks very different and user and password were written
there, but not anymore. Why, or is it me who have done something wrong? When
I log in to phpmyadmin I have to root-accounts there, one with
host=localhost and one the host=%.

All I want, is to make mysql work, so I can test things and to learn!

Thanks
Cassandra

My configuration
Windows XP pro

Netgear router (I have opened port 3306)

ADSL

no-ip (For my domain, www.kamrate.se)
Apache 2.2.2

The exe-files are in c:\apache2\bin

(All I did was to fill in domain=localhost, servername=localhost and my
email)
PHP 5.1.4

The exe-files are in c:\php

(I used the zip package)
httpd.conf

At the row below "#LoadModule ssl_module modules/mod_ssl.so" I wrote:

LoadModule php5_module "c:/php/php5apache2_2.dll
At the row below "AddType application/x-gzip .gz .tgz" I wrote:

AddType application/x-httpd-php .php
At the row below "DocumentRoot" I wrote:

PHPIniDir "C:/php"
At the row below "DocumentRoot" I wrote:

PHPIniDir "C:/php"
At the row "DirectoryIndex index.html" I wrote:

DirectoryIndex index.htm index.html index.php
php.ini

Changed "doc_root" to:

c:\Apache2\htdocs
Created a tmp-folder in:

c:\apache2\ and wrote the path in session.save_path:

c:\apache2\tmp
Saved php.ini in:

c:\php
I did restart apache and tested php and it worked!
Mysql 5.0.22

The exe-files are in c:\mysql\bin
Removed earlier versions of mysql, including the folder:

c:\mysql
I did choose to run "Configuration Wizard" and did choose a password for
root.
PhpMyAdmin

Installationfolder is "c:\apache2\htdocs"

I wrote host=localhost, user=root and password in config.inc.php.
php.ini

I removed the ; before "extension=php_mysql.dll"

I removed the ; before "extension=php_mbstring.dll"
At the row "extension_dir" I wrote:

extension_dir="c:\php\ext"
I copied libmysql.dll in c:\mysql\bin to:

c:\apache2\bin
I did restart apache and tested to surf to http://localhost/phpmyadmin and
it worked!



Maybe ask in a MySQL newsgroup, such as comp.databases.mysql?
--
==================
Remove the "x" from my email address
Jerry Stuckle
JDS Computer Training Corp.
js*******@attglobal.net
==================
Jun 30 '06 #4

P: n/a
> I tried it and it worked. What does -h mean?
mysql --help

I have 2 (4) users for mysql and it is "root" (local and %) with a passord
and "cassandra" (local and %) without a password, that I did create a while
ago because someone did explain that I should do that. What is the
difference between these 2 users, root and cassandra? Which user should I
use and why? Should I have both users and should "cassandra" have a
password?

http://dev.mysql.com/doc/refman/5.0/en/security.html

Don't want to be rude, but this has nothing to do with PHP and thise type of questions should be asked in MySQL forum.
Best regards,
Garbage Monster
Jul 1 '06 #5

P: n/a
Regarding you question about DBDesigner 4 (from alt.comp.databases.mysql):

================ post 1 ==========================
Known bug I'm afraid. The only way I know is to use MySql via ODBC, try it,
it works for me as I had the same problem.
================ post 2 ==========================
You might want to google for this one - it's a known problem when the
MySQL client lib is older than the server or vice versa. MySQL changed
the password encrytion method at some point. There's an option for the
server (--old-password or something like that) that re-establishes the
old behaviour. That should make it work with DBDesigner.

However, AFAIK this product is no longer actively developed. I doubt
that it'll be able to take advantages of the new features in MySQL 5
and afterwards (Stored Procedures, Triggers, Views ...)


news.telia.net wrote:
I tried it and it worked. What does -h mean?

I have 2 (4) users for mysql and it is "root" (local and %) with a passord
and "cassandra" (local and %) without a password, that I did create a while
ago because someone did explain that I should do that. What is the
difference between these 2 users, root and cassandra? Which user should I
use and why? Should I have both users and should "cassandra" have a
password?

I tried to us DBDesigner 4 and I get error when I try to connect to a
database with "root" but not when I use "cassandra". Why?

Thanks


cd C:\Program Files\MySQL\MySQL Server 5.0\bin
mysql -h localhost -u root -p

use mindb

GRANT ALL PRIVILEGES ON *.* TO 'ODBC'@'localhost' IDENTIFIED BY 'yourpass'

WITH GRANT OPTION;

news.telia.net wrote:
Hi!

I have a question. I have installed php and mysql on an apache-server on
windows and I can't connect to the server.

I tried to create a database (since I am trying to learn howto). My manual said I should write this at the shell:
c:\mysql\bin>mysqladmin -u root creare mindb

I did this and got this error:
mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'root'@'localhost' (using password: NO)'

I then tried to use -p and wrote this instead:
c:\mysql\bin>mysqladmin -p -u root creare mindb

The database was created!

Then I tried to write mysql in cmd at c:\mysql\bin but I get this error:
Access denied for user 'ODBC'@'localhost' (using password: No)

Why??

I have used earlier versions of mysql and php and got it to work. In earlier versions "my.ini" looks very different and user and password were written there, but not anymore. Why, or is it me who have done something wrong? When I log in to phpmyadmin I have to root-accounts there, one with
host=localhost and one the host=%.

All I want, is to make mysql work, so I can test things and to learn!

Thanks
Cassandra

My configuration
Windows XP pro

Netgear router (I have opened port 3306)

ADSL

no-ip (For my domain, www.kamrate.se)
Apache 2.2.2

The exe-files are in c:\apache2\bin

(All I did was to fill in domain=localhost, servername=localhost and my
email)
PHP 5.1.4

The exe-files are in c:\php

(I used the zip package)
httpd.conf

At the row below "#LoadModule ssl_module modules/mod_ssl.so" I wrote:

LoadModule php5_module "c:/php/php5apache2_2.dll
At the row below "AddType application/x-gzip .gz .tgz" I wrote:

AddType application/x-httpd-php .php
At the row below "DocumentRoot" I wrote:

PHPIniDir "C:/php"
At the row below "DocumentRoot" I wrote:

PHPIniDir "C:/php"
At the row "DirectoryIndex index.html" I wrote:

DirectoryIndex index.htm index.html index.php
php.ini

Changed "doc_root" to:

c:\Apache2\htdocs
Created a tmp-folder in:

c:\apache2\ and wrote the path in session.save_path:

c:\apache2\tmp
Saved php.ini in:

c:\php
I did restart apache and tested php and it worked!
Mysql 5.0.22

The exe-files are in c:\mysql\bin
Removed earlier versions of mysql, including the folder:

c:\mysql
I did choose to run "Configuration Wizard" and did choose a password for
root.
PhpMyAdmin

Installationfolder is "c:\apache2\htdocs"

I wrote host=localhost, user=root and password in config.inc.php.
php.ini

I removed the ; before "extension=php_mysql.dll"

I removed the ; before "extension=php_mbstring.dll"
At the row "extension_dir" I wrote:

extension_dir="c:\php\ext"
I copied libmysql.dll in c:\mysql\bin to:

c:\apache2\bin
I did restart apache and tested to surf to http://localhost/phpmyadmin and it worked!



Jul 1 '06 #6

This discussion thread is closed

Replies have been disabled for this discussion.