By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
459,724 Members | 1,184 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 459,724 IT Pros & Developers. It's quick & easy.

Apache & PHP installation/configuration problem

P: n/a
Hello, can anyone help me, I am new to PHP.

I am trying to set up the Apache Server for PHP (in Windows XP), but when I
ad the line:

LoadModule php4_module c:/php-4.2.3-Win32/sapi/php4apache2.dll

(in httpd.conf), then the Apache Server refuces to start (I get "The
requested operation has failed" msg).

Without that line the Apache Server starts with no problems. The directory
path is correct.

Please help me!
Jul 17 '05 #1
Share this Question
Share on Google+
4 Replies


P: n/a
On Fri, 19 Mar 2004 23:04:46 +0200, "Panos Hadjikomninos"
<ga********@panafonet.gr> wrote:
Hello, can anyone help me, I am new to PHP.

I am trying to set up the Apache Server for PHP (in Windows XP), but when I
ad the line:

LoadModule php4_module c:/php-4.2.3-Win32/sapi/php4apache2.dll

(in httpd.conf), then the Apache Server refuces to start (I get "The
requested operation has failed" msg).

Without that line the Apache Server starts with no problems. The directory
path is correct.


Look in the Windows event log, there will be more information there.

--
Andy Hassall <an**@andyh.co.uk> / Space: disk usage analysis tool
<http://www.andyh.co.uk> / <http://www.andyhsoftware.co.uk/space>
Jul 17 '05 #2

P: n/a
puk
Andy Hassall wrote:
On Fri, 19 Mar 2004 23:04:46 +0200, "Panos Hadjikomninos"
<ga********@panafonet.gr> wrote:
Hello, can anyone help me, I am new to PHP.

I am trying to set up the Apache Server for PHP (in Windows XP), but
when I ad the line:

LoadModule php4_module c:/php-4.2.3-Win32/sapi/php4apache2.dll

(in httpd.conf), then the Apache Server refuces to start (I get "The
requested operation has failed" msg).

Without that line the Apache Server starts with no problems. The
directory path is correct.


Look in the Windows event log, there will be more information there.

You could try changing the dots to underscores between the 4.2.3
and also rename the directory likewise - just a hunch.
LoadModule php4_module c:/php-4_2_3-Win32/sapi/php4apache2.dll

Neil
Jul 17 '05 #3

P: n/a
remember that is currently recommended that you use Apache 1.3.x and not
Apache 2 for PHP...

at http://www.php.net/manual/en/install.apache.php (especially steps 14-17)
there is instructions on configuring Apache 1.3.x for PHP. they also have
instructions for configuring Apache 2 but it is experimental and not
completely reliable.

hope this helps

- JP

----- Original Message -----
From: "Panos Hadjikomninos" <ga********@panafonet.gr>
Newsgroups: comp.lang.php
Sent: Friday, March 19, 2004 4:04 PM
Subject: Apache & PHP installation/configuration problem

Hello, can anyone help me, I am new to PHP.

I am trying to set up the Apache Server for PHP (in Windows XP), but when I ad the line:

LoadModule php4_module c:/php-4.2.3-Win32/sapi/php4apache2.dll

(in httpd.conf), then the Apache Server refuces to start (I get "The
requested operation has failed" msg).

Without that line the Apache Server starts with no problems. The directory
path is correct.

Please help me!

Jul 17 '05 #4

P: n/a
You didn't copy php4ts.dll into C:\Windows\System32, that's the problem.
(You can also put the file in the sapi folder.)

Uzytkownik "Panos Hadjikomninos" <ga********@panafonet.gr> napisal w
wiadomosci news:c3***********@ulysses.noc.ntua.gr...
Hello, can anyone help me, I am new to PHP.

I am trying to set up the Apache Server for PHP (in Windows XP), but when I ad the line:

LoadModule php4_module c:/php-4.2.3-Win32/sapi/php4apache2.dll

(in httpd.conf), then the Apache Server refuces to start (I get "The
requested operation has failed" msg).

Without that line the Apache Server starts with no problems. The directory
path is correct.

Please help me!

Jul 17 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.