By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
443,974 Members | 1,913 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 443,974 IT Pros & Developers. It's quick & easy.

Komodo/PHP/MySQL Problem

P: n/a
Hi all,

I have setup PHP/MySQL (using mysqli) and works properly from the
command line. Here is the code that works when run from the command
line:

<?php
$conn = new mysqli('localhost','root','xyz'','testdb');
if (mysqli_connect_errno() != 0)
{
$message=mysqli_connect_error();
}
?>

Now I want to use Komodo for the IDE/Debugger. When I set the Komodo
debugger to use PHP-WIN.EXE I get a CLI error. Someone said there is a
problem with Komodo and CLI (I assume this means the .NET stuff)

I then switch the Komodo debugger to use PHP-CGI.EXE and I get the
message below:
PHP Fatal error: Class 'mysqli' not found in
C:\PHP5Apps\Astir\PHP-1.php on line 5

I am at a loss, as I cant seem to be able to to debug either way with
Komodo. (I could switch but I already paid for it and runs on both
Linux and Windows.).

Anyone can help me?

Thanks

Apr 17 '06 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Ok figured it out.

1) I had to set in PHP.INI this path:

; Directory in which the loadable extensions (modules) reside.
extension_dir = "C:\PHP5\ext"

2) I had to rerun the Komodo Debug Wizard which added a couple of lines
at the very top of PHP.INI in a backup folder.

Also, found out that extension_dir only allows one path. You cant
semicolon paths it seems.

Whew!

Apr 17 '06 #2

This discussion thread is closed

Replies have been disabled for this discussion.