470,848 Members | 1,708 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 470,848 developers. It's quick & easy.

./configure --with-headaches

Trying to compile PHP 5 beta 4, and not having much fun...

% ./configure --with-apxs --with-mod_charset --with-zlib --with-bz2
--with-curl --with-gd --with-mhash --with-pspell --enable-sqlite-utf8
--with-tidy --disable-libxml
....[snip]...
checking for BZip2 support... yes
checking for BZip2 in default path... found in /usr
checking for BZ2_bzerror in -lbz2... no
configure: error: bz2 module requires libbz2 >= 1.0.0
% where bzip2
/sw/bin/bzip2
% bzip2 -V
bzip2, a block-sorting file compressor. Version 1.0.2, 30-Dec-2001.

Why is it finding BZip2 in /usr, when it's *not* in /usr, it's in
/sw/bin? And, as you can see, the version most certainly is >= 1.0.0. I
tried putting --with-bz2-dir=/sw/bin/ in the ./configure command, but
that has no effect. If I leave out --with-bz2, it then whines in a
similar manner with curl (which is also in /sw/bin). Is there just a way
to tell it to use the same damn bzip2 I access when I type "bzip2"?

Can't get libxml to work either, hence why I have it --disabled above;
but I can't remember what exactly was wrong with that as it is four in
the morning.

TIA for any help you can provide.
Jul 17 '05 #1
3 6382
Garrett Albright <i@think.not> wrote:
Trying to compile PHP 5 beta 4, and not having much fun...

% ./configure --with-apxs --with-mod_charset --with-zlib --with-bz2
--with-curl --with-gd --with-mhash --with-pspell --enable-sqlite-utf8
--with-tidy --disable-libxml
...[snip]...
checking for BZip2 support... yes
checking for BZip2 in default path... found in /usr
checking for BZ2_bzerror in -lbz2... no
configure: error: bz2 module requires libbz2 >= 1.0.0
% where bzip2
/sw/bin/bzip2
% bzip2 -V
bzip2, a block-sorting file compressor. Version 1.0.2, 30-Dec-2001.

Why is it finding BZip2 in /usr, when it's *not* in /usr, it's in
/sw/bin? And, as you can see, the version most certainly is >= 1.0.0. I
tried putting --with-bz2-dir=/sw/bin/ in the ./configure command, but
that has no effect. If I leave out --with-bz2, it then whines in a
similar manner with curl (which is also in /sw/bin). Is there just a way
to tell it to use the same damn bzip2 I access when I type "bzip2"?

Can't get libxml to work either, hence why I have it --disabled above;
but I can't remember what exactly was wrong with that as it is four in
the morning.


I don't know if it'll help or not.. but you might try:

--with-bz2=/sw

I believe it's looking for the headers and libraries, NOT the actual
binary executable.

Compiling stuff on a mac (which is what I assume you've got, with fink)
can be really touchy in my experience.

Jamie
Jul 17 '05 #2
Garrett Albright wrote:
Trying to compile PHP 5 beta 4, and not having much fun...

% ./configure --with-apxs --with-mod_charset --with-zlib --with-bz2
--with-curl --with-gd --with-mhash --with-pspell --enable-sqlite-utf8
--with-tidy --disable-libxml
...[snip]...
checking for BZip2 support... yes
checking for BZip2 in default path... found in /usr
checking for BZ2_bzerror in -lbz2... no
configure: error: bz2 module requires libbz2 >= 1.0.0


I'm not an expert in compilation but you should try this:

% for a in `cat /etc/ld.so.conf` ; do \
echo $a ; ls $a | grep bz2 ; done

On my system, I got various messages including:

/usr/lib
libbz2.a
libbz2.la
libbz2.so
libbz2.so.1
libbz2.so.1.0.0

These are the files needed by the compilation. If these files don't appear
with my tiny script, first check that the user doing the compilation has the
needed access rights to all library folders. Any way, find the libbz2.* and
check that the path is in your ld.so.conf and accessible.

Them same applies to "curl" and "xml". Let's customize our little script:

% cat > checklib <<EOF
for a in `cat /etc/ld.so.conf` ; do \
echo $a ; ls $a | grep $1 ; done
EOF
% chmod +x ./checklib

% ./checklib curl

% ./checklib xml

I just noticed that all these libs are in /usr/lib on my system. I think
that either you have no /usr at all or the path to these libs isn't in your
ld.so.conf.

See ya,

================
Remi Villatel
ma*****@tele2.fr
================
Jul 17 '05 #3
th******@yahoo.com wrote:
I don't know if it'll help or not.. but you might try:

--with-bz2=/sw
Thanks for the suggestion, but this does not supress the error.
Compiling stuff on a mac (which is what I assume you've got, with fink)
can be really touchy in my experience.
A correct assumption. Fink works 99% of the time; it's great. Just push
a button and it installs! Idiot-proof. I *really* wish there were a PHP
5 package on Fink right about now.

Remi Villatel wrote: I'm not an expert in compilation but you should try this:

% for a in `cat /etc/ld.so.conf` ; do \
echo $a ; ls $a | grep bz2 ; done


Thank you for putting so much effort into your reply, but I've got to
stop you here; there is no /etc/ld.so.conf on my machine, nor is there a
ld.so.conf in any other directory.
Jul 17 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

reply views Thread by Christopher De Vries | last post: by
reply views Thread by Markus Wollny | last post: by
reply views Thread by Samuel M. Smith | last post: by
1 post views Thread by Markus Wollny | last post: by
14 posts views Thread by david | last post: by
reply views Thread by Satish S Nandihalli | last post: by
1 post views Thread by Jim McCullars | last post: by
7 posts views Thread by Mathieu Prevot | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.