By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
444,017 Members | 1,169 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 444,017 IT Pros & Developers. It's quick & easy.

only two concurrent php scripts at a time

P: n/a
em
hi,
i can't make more than two concurrent requests to a php script - i mean
when i make say 20 simultaneous requests then two first execute but 18 remaining
are waiting for them, then the next two scripts are handled and so on.
why only two? how to change that?
it's not session locking for sure - i use session_write_close,
and actually i stripped down my script so that now has just some
slow-down loop.
it's php 4.2 and apache 2, linux
regards
em
Jan 20 '06 #1
Share this Question
Share on Google+
3 Replies


P: n/a
Apache limits it to two defaultly. I believe it's the MaxClients
directive in the httpd.conf.

Jan 20 '06 #2

P: n/a
em
> Apache limits it to two defaultly. I believe it's the MaxClients
directive in the httpd.conf.


No, MaxClients is usually more than 100. The problem was in Firefox and IE
- they have a limit of 2 concurrent connections to one server... :/
Thanks anyway,
em
Jan 21 '06 #3

P: n/a
d
"em" <ex*****@example.com> wrote in message
news:dq**********@inews.gazeta.pl...
Apache limits it to two defaultly. I believe it's the MaxClients
directive in the httpd.conf.


No, MaxClients is usually more than 100. The problem was in Firefox and IE
- they have a limit of 2 concurrent connections to one server... :/
Thanks anyway,
em


You can get round that by using subdomains. That'll give you as many
connections as you want:

site1.mysite.com
site2.mysite.com

etc.
Jan 23 '06 #4

This discussion thread is closed

Replies have been disabled for this discussion.