470,848 Members | 1,723 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 470,848 developers. It's quick & easy.

anyway to exceed max execution time?

Hello all;

I set "max_execution_time = 120" in my php.ini file so that some lengthy php
routines in my auction software would have time to complete when
automatically relisting lots of items.

However, sometimes even 2 minutes is not long enough. I don't want to
increase the max time to 10 or 15 minutes, so I'm wondering if there is any
way to allow a specific PHP file to exceed the max_execution_time?

TIA.

Charles...
Jan 11 '06 #1
6 14135

"Charles Crume" <NO*******@charlescrumesoftware.com> wrote in message
news:Wz******************@tornado.ohiordc.rr.com.. .
Hello all;

I set "max_execution_time = 120" in my php.ini file so that some lengthy
php routines in my auction software would have time to complete when
automatically relisting lots of items.

However, sometimes even 2 minutes is not long enough. I don't want to
increase the max time to 10 or 15 minutes, so I'm wondering if there is
any way to allow a specific PHP file to exceed the max_execution_time?

TIA.

Charles...


set_time_limit(yourlimit)
http://www.php.net/set-time-limit
or ini_set('max_execution_time',yourlimit);
http://www.php.net/ini_set
I hope that's what you need.
Cheers.
--
----
Leonardo Armando Iarrusso - J2Be
www: http://www.J2be.com - e-mail: info[at]J2Be.com
Jan 11 '06 #2
Charles Crume wrote [reformatted]:
is there any way to allow a specific PHP file
to exceed the max_execution_time?


http://www.php.net/set_time_limit

--
Mail to my "From:" address is readable by all at http://www.dodgeit.com/
== ** ## !! ------------------------------------------------ !! ## ** ==
TEXT-ONLY mail to the whole "Reply-To:" address ("My Name" <my@address>)
may bypass my spam filter. If it does, I may reply from another address!
Jan 11 '06 #3
max_execution_time = 0
This option is equivalent to have infinite time

Jan 11 '06 #4
C.
....but do you really expect your users to wait that long. And not click
the 'submit' button again.

You need to fix the real problem - not fix the problems in the
workaround.

C.

Jan 11 '06 #5

<to*****@gmail.com> wrote in message
news:11**********************@f14g2000cwb.googlegr oups.com...
max_execution_time = 0
This option is equivalent to have infinite time


No, don't want to set it to unlimited, just a little longer than normal.
Jan 11 '06 #6

"J2be" <in**@nospamj2be.com> wrote in message
news:43**********************@reader4.news.tin.it. ..

[snip]
set_time_limit(yourlimit)
http://www.php.net/set-time-limit
or ini_set('max_execution_time',yourlimit);
http://www.php.net/ini_set
I hope that's what you need.


Yes, that's what I am looking for.

Thanks!!!!
Jan 11 '06 #7

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

5 posts views Thread by Johannes Lebek | last post: by
7 posts views Thread by Tim Quon | last post: by
2 posts views Thread by Ina Schmitz | last post: by
6 posts views Thread by Mikhail Kovalev | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.