By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,435 Members | 2,891 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,435 IT Pros & Developers. It's quick & easy.

PEAR gives open_basedir restriction on IIS server

P: n/a
On a previous installed server my site which uses several PEAR-packages
worked fine.
Now it's transfered to a new server. (Both servers installed with
Windows 2003 / IIS 6, on the previous server the PHP version was 5.03,
on the new one 5.05)

The site gives a open_basedir restriction on this new server. In the
php.ini the open_basedir line is commented, but when I run the command
phpinfo() there appears to be a local value, which I didn't set. Does
anyone know how to solve this problem, or some things I can try?

Here is the output of phpinfo();

include_path .;C:\php\pear;c:\php\ .;C:\php\pear;c:\php\
log_errors On On
log_errors_max_len 1024 1024
magic_quotes_gpc Off Off
magic_quotes_runtime Off Off
magic_quotes_sybase Off Off
mail.force_extra_parameters no value no value
max_execution_time 45 45
max_input_time 60 60
open_basedir D:\webspace\web32\xxx\xxxx no value


This is the error on my site :

Warning: main() [function.main]: open_basedir restriction in effect.
File(C:\php\pear/PEAR/HTML/QuickForm.php) is not within the allowed
path(s): (D:\webspace\web32\xxx\xxxx) in
d:\webspace\web32\xxx\xxx\www\includes.php on line 12

Warning: main(PEAR/HTML/QuickForm.php) [function.main]: failed to open
stream: Operation not permitted in
d:\webspace\web32\xxx\xxx\www\includes.php on line 12

Fatal error: main() [function.require]: Failed opening required
'PEAR/HTML/QuickForm.php' (include_path='.;C:\php\pear;c:\php\') in
d:\webspace\web32\xxxx\xxx\www\includes.php on line 12

Jan 4 '06 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.