By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,947 Members | 1,594 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,947 IT Pros & Developers. It's quick & easy.

linux, php,cvs, curl instlling problem

P: n/a
Hello

I checked out openssl,mm,apr,apr-util,apache 2,curl,libxml and php
from cvs.

php couse an ERROR

I did the following steps:

export ORACLE_BASE=/usr/local/share/oracle/
export ORACLE_HOME=/usr/local/share/oracle/OraHome1
export ORACLE_DOC=$ORACLE_BASE/doc
export ORACLE_SID=udb
export TWO_TASK=udb.suchtreffer.de
export PATH=$PATH:/usr/local/share/oracle/OraHome1/bin
export LD_LIBRARY_PATH=$ORACLE_HOME/lib
export CLASSPATH=/usr/local/share/oracle/jre:$ORACLE_HOME/jlib
export NLS_LANG='ENGLISH_UNITED KINGDOM.WE8ISO8859P1'
export ORA_NLS33=/usr/local/share/oracle/OraHome1/ocommon/nls/admin/data
openssl:
cd /usr/local/src
rsync -rztpv --delete rsync://dev.openssl.org/openssl-cvs/
/usr/local/src/openssl-cvs-rsync/
cvs -d /usr/local/src/openssl-cvs-rsync co openssl
cd ./openssl
config no-idea no-threads -fPIC
make
make test
make install

mm:
cd /usr/local/src
download mm-1.3.0.tar.gz (http://www.ossp.org/pkg/lib/mm/)
tar -zxvpf mm-1.3.0.tar.gz
cd ./mm-1.3.0
../configure --disable-shared
make
make install

apr:
cd /usr/local/src
cvs -d :pserver:an*****@cvs.apache.org:/home/cvspublic login
Password: anoncvs cvs -d :pserver:an*****@cvs.apache.org:/home/cvspublic co apr
cd ./apr
../buildconf
../configure
make
make install

apr-util:
cd /usr/local/src
cvs -d :pserver:an*****@cvs.apache.org:/home/cvspublic co apr-util
cd ./apr-util
../buildconf
../configure --with-apr=../apr
make
make install

apache 2:
cd /usr/local/src
cvs -d :pserver:an*****@cvs.apache.org:/home/cvspublic co -d httpd
httpd-2.0
cd ./httpd/srclib
ln -s /usr/local/src/apr .
ln -s /usr/local/src/apr-util .
cd ..
../buildconf
../configure --prefix=/usr/local --with-apr=../apr
--with-apr-util=../apr-util/ --with-ssl=/usr/local/ssl --enable-ssl
make
make install

curl:
cd /usr/local/src
cvs -d :pserver:cv*****@cvs.php.net:/repository login Password: phpfi cvs -d :pserver:cv*****@cvs.php.net:/repository checkout curl
cd ./curl
../buildconf
../configure --prefix=/usr/local --disable-ipv6
--with-ssl=/usr/local/ssl
make
make install
libxml2:

cd /usr/local/src
cvs -d :pserver:an*******@anoncvs.gnome.org:/cvs/gnome login Password: [RETURN]

cvs -d :pserver:an*******@anoncvs.gnome.org:/cvs/gnome co libxml2
cd ./libxml2
../autogen.sh
make
make install
php:
cd /usr/local/src
cvs -d :pserver:cv*****@cvs.php.net:/repository co -d php php-src
cd ./php
../buildconf
../configure --with-apache2=../httpd --enable-sysvshm=yes
--enable-url-includes --enable-track-vars=yes --enable-trans-sid=yes
--with-xml=../libxml2 --enable-magic-quotes --enable-ftp
--with-oracle=$ORACLE_HOME --with-oci8=$ORACLE_HOME --enable-sigchild
--with-mysql --with-openssl=/usr/local/ssl --with-curl=usr/local/lib
--with-curlwrappers
make

now I get an Error-Message:

gcc -Iext/curl/ -I/usr/local/src/php/ext/curl/ -DPHP_ATOM_INC
-I/usr/local/src/php/include -I/usr/local/src/php/main
-I/usr/local/src/php -I/usr/local/src/php/Zend
-I/usr/local/include/libxml2 -I/usr/local/ssl/include
-I/usr/local/include -I/usr/include/mysql
-I/usr/local/share/oracle/OraHome1/rdbms/public
-I/usr/local/share/oracle/OraHome1/rdbms/demo
-I/usr/local/src/php/TSRM -g -O2 -c
/usr/local/src/php/ext/curl/interface.c -o ext/curl/interface.o &&
echo > ext/curl/interface.lo
/usr/local/src/php/ext/curl/interface.c: In function `curl_free_post':
/usr/local/src/php/ext/curl/interface.c:643: warning: passing arg 1 of
`curl_formfree' from incompatible pointer type
/usr/local/src/php/ext/curl/interface.c: In function
`alloc_curl_handle':
/usr/local/src/php/ext/curl/interface.c:711: sizeof applied to an
incomplete type
/usr/local/src/php/ext/curl/interface.c: In function
`zif_curl_setopt':
/usr/local/src/php/ext/curl/interface.c:999: warning: passing arg 1 of
`curl_formadd' from incompatible pointer type
/usr/local/src/php/ext/curl/interface.c:999: warning: passing arg 2 of
`curl_formadd' from incompatible pointer type
/usr/local/src/php/ext/curl/interface.c:1006: warning: passing arg 1
of `curl_formadd' from incompatible pointer type
/usr/local/src/php/ext/curl/interface.c:1006: warning: passing arg 2
of `curl_formadd' from incompatible pointer type
make: *** [ext/curl/interface.lo] Error 1

I also tried to configure php with
--with-curl=/usr/local/lib
--with-curl=/usr/local/include/curl
--with-curl=/usr/local/src/curl/include/curl/
Can you help ?
please !
Jul 17 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Haluk Durmus wrote:
Hello

I checked out openssl,mm,apr,apr-util,apache 2,curl,libxml and php
from cvs.

php couse an ERROR

I did the following steps:

export ORACLE_BASE=/usr/local/share/oracle/
export ORACLE_HOME=/usr/local/share/oracle/OraHome1
export ORACLE_DOC=$ORACLE_BASE/doc
export ORACLE_SID=udb
export TWO_TASK=udb.suchtreffer.de
export PATH=$PATH:/usr/local/share/oracle/OraHome1/bin
export LD_LIBRARY_PATH=$ORACLE_HOME/lib
export CLASSPATH=/usr/local/share/oracle/jre:$ORACLE_HOME/jlib
export NLS_LANG='ENGLISH_UNITED KINGDOM.WE8ISO8859P1'
export ORA_NLS33=/usr/local/share/oracle/OraHome1/ocommon/nls/admin/data
openssl:
cd /usr/local/src
rsync -rztpv --delete rsync://dev.openssl.org/openssl-cvs/
/usr/local/src/openssl-cvs-rsync/
cvs -d /usr/local/src/openssl-cvs-rsync co openssl
cd ./openssl
config no-idea no-threads -fPIC
make
make test
make install

mm:
cd /usr/local/src
download mm-1.3.0.tar.gz (http://www.ossp.org/pkg/lib/mm/)
tar -zxvpf mm-1.3.0.tar.gz
cd ./mm-1.3.0
./configure --disable-shared
make
make install

apr:
cd /usr/local/src
cvs -d :pserver:an*****@cvs.apache.org:/home/cvspublic login
> Password: anoncvs

cvs -d :pserver:an*****@cvs.apache.org:/home/cvspublic co apr
cd ./apr
./buildconf
./configure
make
make install

apr-util:
cd /usr/local/src
cvs -d :pserver:an*****@cvs.apache.org:/home/cvspublic co apr-util
cd ./apr-util
./buildconf
./configure --with-apr=../apr
make
make install

apache 2:
cd /usr/local/src
cvs -d :pserver:an*****@cvs.apache.org:/home/cvspublic co -d httpd
httpd-2.0
cd ./httpd/srclib
ln -s /usr/local/src/apr .
ln -s /usr/local/src/apr-util .
cd ..
./buildconf
./configure --prefix=/usr/local --with-apr=../apr
--with-apr-util=../apr-util/ --with-ssl=/usr/local/ssl --enable-ssl
make
make install

curl:
cd /usr/local/src
cvs -d :pserver:cv*****@cvs.php.net:/repository login
> Password: phpfi

cvs -d :pserver:cv*****@cvs.php.net:/repository checkout curl
cd ./curl
./buildconf
./configure --prefix=/usr/local --disable-ipv6
--with-ssl=/usr/local/ssl
make
make install
libxml2:

cd /usr/local/src
cvs -d :pserver:an*******@anoncvs.gnome.org:/cvs/gnome login
> Password: [RETURN]

cvs -d :pserver:an*******@anoncvs.gnome.org:/cvs/gnome co libxml2
cd ./libxml2
./autogen.sh
make
make install
php:
cd /usr/local/src
cvs -d :pserver:cv*****@cvs.php.net:/repository co -d php php-src
cd ./php
./buildconf
./configure --with-apache2=../httpd --enable-sysvshm=yes
--enable-url-includes --enable-track-vars=yes --enable-trans-sid=yes
--with-xml=../libxml2 --enable-magic-quotes --enable-ftp
--with-oracle=$ORACLE_HOME --with-oci8=$ORACLE_HOME --enable-sigchild
--with-mysql --with-openssl=/usr/local/ssl --with-curl=usr/local/lib
--with-curlwrappers
make

now I get an Error-Message:

gcc -Iext/curl/ -I/usr/local/src/php/ext/curl/ -DPHP_ATOM_INC
-I/usr/local/src/php/include -I/usr/local/src/php/main
-I/usr/local/src/php -I/usr/local/src/php/Zend
-I/usr/local/include/libxml2 -I/usr/local/ssl/include
-I/usr/local/include -I/usr/include/mysql
-I/usr/local/share/oracle/OraHome1/rdbms/public
-I/usr/local/share/oracle/OraHome1/rdbms/demo
-I/usr/local/src/php/TSRM -g -O2 -c
/usr/local/src/php/ext/curl/interface.c -o ext/curl/interface.o &&
echo > ext/curl/interface.lo
/usr/local/src/php/ext/curl/interface.c: In function `curl_free_post':
/usr/local/src/php/ext/curl/interface.c:643: warning: passing arg 1 of
`curl_formfree' from incompatible pointer type
/usr/local/src/php/ext/curl/interface.c: In function
`alloc_curl_handle':
/usr/local/src/php/ext/curl/interface.c:711: sizeof applied to an
incomplete type
/usr/local/src/php/ext/curl/interface.c: In function
`zif_curl_setopt':
/usr/local/src/php/ext/curl/interface.c:999: warning: passing arg 1 of
`curl_formadd' from incompatible pointer type
/usr/local/src/php/ext/curl/interface.c:999: warning: passing arg 2 of
`curl_formadd' from incompatible pointer type
/usr/local/src/php/ext/curl/interface.c:1006: warning: passing arg 1
of `curl_formadd' from incompatible pointer type
/usr/local/src/php/ext/curl/interface.c:1006: warning: passing arg 2
of `curl_formadd' from incompatible pointer type
make: *** [ext/curl/interface.lo] Error 1

I also tried to configure php with
--with-curl=/usr/local/lib
--with-curl=/usr/local/include/curl
--with-curl=/usr/local/src/curl/include/curl/
Can you help ?
please !


I solved it by my selfe.
I switched CURL down to curl_7_10_5.
now it's working :)
Jul 17 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.