By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
444,078 Members | 1,846 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 444,078 IT Pros & Developers. It's quick & easy.

Grant not working

P: n/a
I am doing something wrong or have something set up wrong.

When I issue

mysql> grant all on * to mike identified by 'joented' with grant
option;
Query OK, 0 rows affected (0.69 sec)

It looks like the grant worked. Here is what the mysql.user table looks
like.

mysql> select user,password, host from mysql.user;
+---------+---------------------+-----------+
| user | password | host |
+---------+---------------------+-----------+
| root | | localhost |
| root | | % |
| | 3823a5ee1f831626 | localhost |
| | | % |
| bruceaj | 426d920b373a5e5b | % |
| mike | 426d920b373a5e5b | % |
| peter | 426d920b373a5e5b | % |
| jim | 426d920b373a5e5b | % |
+---------+-----------------==-+-----------+

Now, when I issue a mysql command for mike, I get

C:\mysql\bin>mysql -u mike -pjoented;
ERROR 1045: Access denied for user: 'mike@localhost' (Using password:
YES)

The ONLY User I can login as is root, as:

mysql -u root

Appreciate your help in identifing what what I have screwed up, and how do I
fix it.

Thanks.....

Bruce
Jul 17 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
On 2003-12-18, Bruce A. Julseth <br*****@attglobal.net> wrote:
When I issue

mysql> grant all on * to mike identified by 'joented' with grant
option;
Query OK, 0 rows affected (0.69 sec)

It looks like the grant worked.


If i remember well, the manual says that you have to reload...

mysqladmin -u root -p reload
--
verum ipsum factum
Jul 17 '05 #2

P: n/a
Tim Van Wassenhove wrote:
On 2003-12-18, Bruce A. Julseth <br*****@attglobal.net> wrote:
When I issue

mysql> grant all on * to mike identified by 'joented' with grant
option;
Query OK, 0 rows affected (0.69 sec)

It looks like the grant worked.

If i remember well, the manual says that you have to reload...

mysqladmin -u root -p reload


or
mysqladmin -u root -p flush-privileges

.... also not that you shouldn't publish passwords so you ought to change it.

Jul 17 '05 #3

P: n/a
I tried both,
mysqladmin -u root flush-privileges
and
mysqladmin -u root reload

NOTE: root has no password on purpose.

I still fail with the following scenario:

C:\Documents and Settings\Bruce A. Julseth>mysql -u root
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 8 to server version: 4.0.14-max-debug

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql> grant all on * to mike identified by 'joented' with grant
option;
Query OK, 0 rows affected (0.65 sec)

mysql> quit
Bye

C:\Documents and Settings\Bruce A. Julseth>mysql -u mike -pjoented
ERROR 1045: Access denied for user: 'mike@localhost' (Using password:
YES)

As for the "Open" password, this development is going on a private,
non-networked machine. But thanks for catching the potenial problem.

Now, I hope you folks out there is PHP land can provide some more
suggestions.

Bruce

"Kevin Thorpe" <ke***@pricetrak.com> wrote in message
news:3F**************@pricetrak.com...
Tim Van Wassenhove wrote:
On 2003-12-18, Bruce A. Julseth <br*****@attglobal.net> wrote:
When I issue

mysql> grant all on * to mike identified by 'joented' with grant
option;
Query OK, 0 rows affected (0.69 sec)

It looks like the grant worked.

If i remember well, the manual says that you have to reload...

mysqladmin -u root -p reload


or
mysqladmin -u root -p flush-privileges

... also not that you shouldn't publish passwords so you ought to change

it.

Jul 17 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.