By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,972 Members | 883 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,972 IT Pros & Developers. It's quick & easy.

php 4.3.4

P: n/a
I am running php in Apache on Windows98SE PC

I have been using php version 4.3.3 and everything worked OK except the
mcrypt function didn't work.
Because of this, I upgraded to version 4.3.4 and mcrypt now works OK but my
hyperlinks to other pages no longer work. It simply jumps back to the same
page.
The page number in the address bar changes, e.g /index.php?page=3 changes
to:- /index.php?page=5 but the displayed page is still the same.

If I go back to using version 4.3.3 again, all is OK.
Did I miss something when I installed 4.3.4?

Thanks for any help.

Geoff.

Jul 17 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
*** Geoff wrote/escribió (Fri, 12 Dec 2003 10:45:50 -0000):
The page number in the address bar changes, e.g /index.php?page=3 changes
to:- /index.php?page=5 but the displayed page is still the same.

If I go back to using version 4.3.3 again, all is OK.
Did I miss something when I installed 4.3.4?


How do you handle the page value, $_GET['page'] or $page? If it's the
latest, you probably have auto register_globals set to off in new version.
Check that in php.ini file.
--
--
-- Álvaro G. Vicario - Burgos, Spain
--
Jul 17 '05 #2

P: n/a
Yes! That solved the problem.

Many thanks for your help.

Geoff.
"Alvaro G Vicario" <al******************@telecomputeronline.com> wrote in
message news:in****************************@40tude.net...
*** Geoff wrote/escribió (Fri, 12 Dec 2003 10:45:50 -0000):
The page number in the address bar changes, e.g /index.php?page=3 changes to:- /index.php?page=5 but the displayed page is still the same.

If I go back to using version 4.3.3 again, all is OK.
Did I miss something when I installed 4.3.4?


How do you handle the page value, $_GET['page'] or $page? If it's the
latest, you probably have auto register_globals set to off in new version.
Check that in php.ini file.
--
--
-- Álvaro G. Vicario - Burgos, Spain
--

Jul 17 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.