By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
428,600 Members | 1,214 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 428,600 IT Pros & Developers. It's quick & easy.

php.ini is not refreshing/being read when apache is restart

P: n/a
I am running php 4.3.4 Win 32 as a module with Apache 1.3.29.
I am trying show this modification in the php.ini file

session.save_path = C:\PHP\phpsessiondata

But when I restart then then go into PEAR to begin an install I
allways have the following errors at the bottom of the page.

Any ideas ?

- Eric

Warning: Unknown(): open(/tmp\sess_3476e5826cc724d730b79148be0386ab,
O_RDWR) failed: No such file or directory (2) in Unknown on line 0

Warning: Unknown(): Failed to write session data (files). Please
verify that the current setting of session.save_path is correct (/tmp)
in Unknown on line 0
Jul 17 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
"Charon" a écrit le 12/12/2003 :
Any ideas ?

- Eric

Warning: Unknown(): open(/tmp\sess_3476e5826cc724d730b79148be0386ab,
O_RDWR) failed: No such file or directory (2) in Unknown on line 0

Warning: Unknown(): Failed to write session data (files). Please
verify that the current setting of session.save_path is correct (/tmp)
in Unknown on line 0


Beware of / and \ in file path.
Try to change your /tmp to \tmp

--
Have you read the manual?
http://www.php.net/manual/en/

Jul 17 '05 #2

P: n/a
Jedi121 <je*********@free.fr.Removethis> wrote in message news:<me********************************@free.fr.R emovethis>...
"Charon" a écrit le 12/12/2003 :
Any ideas ?

- Eric

Warning: Unknown(): open(/tmp\sess_3476e5826cc724d730b79148be0386ab,
O_RDWR) failed: No such file or directory (2) in Unknown on line 0

Warning: Unknown(): Failed to write session data (files). Please
verify that the current setting of session.save_path is correct (/tmp)
in Unknown on line 0


Beware of / and \ in file path.
Try to change your /tmp to \tmp


That's not the problem
It would not read any change that was made to the php.ini file.
I has since updated the changes but only once a reboot. It may have
something to do with IIS but I am using IIS that is running on another
computer ??
Jul 17 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.