By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
432,441 Members | 996 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 432,441 IT Pros & Developers. It's quick & easy.

building php from source, pear doesn't install even when told to

P: n/a
usinng php-4.3.4

using this for my configure script;
../configure --with-pear=/usr/local/lib/pear --with-mysql --with-apxs=/usr/sb
in/apxs --enable-track-vars --with-mysql-sock=/tmp/mysql.sock

then make; make install

output says it installed pear:
[root @ silence ] : make install
Installing PHP CLI binary: /usr/local/bin/
Installing PHP CLI man page: /usr/local/man/man1/
Installing PHP SAPI module: apache
[activating module `php4' in /var/www/conf/httpd.conf]
cp libs/libphp4.so /usr/lib/apache/modules/libphp4.so
chmod 755 /usr/lib/apache/modules/libphp4.so
cp /var/www/conf/httpd.conf /var/www/conf/httpd.conf.bak
cp /var/www/conf/httpd.conf.new /var/www/conf/httpd.conf
rm /var/www/conf/httpd.conf.new
Installing shared extensions:
/usr/local/lib/php/extensions/no-debug-non-zts-20020429/
Installing PEAR environment: /usr/local/lib/pear/
Installing build environment: /usr/local/lib/php/build/
Installing header files: /usr/local/include/php/
Installing helper programs: /usr/local/bin/
program: phpize
program: php-config
program: phpextdist

but all it does is create the directory /usr/local/lib/pear. nothing get's
put there.

any help would be really appreciated.
Jul 17 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.