By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
455,040 Members | 1,178 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 455,040 IT Pros & Developers. It's quick & easy.

apache and php horor part 2

P: n/a
Hi,

Tried installation with apache 2.0.47. But nothing is working. Copied all
the dll's
and .ini file to the right locations. Changed the httpd.conf file as well.

Here is what I added in httpd.conf

LoadModule php4_module "c:/php/sapi/php4apache2.dll"
ScriptAlias /php4/ "C:/php"
AddType application/x-httpd-php4 .php"
Action application/x-httpd-php4 "php4/php.exe"

Start up apache is ok. But when I try to to this

<?php
phpinfo();
?>

in my index.html nothing is showed up. I also cannot browse .php files in my
browser

regards

Johan
Jul 17 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
sk
Johan den Boer wrote:
Hi,

Tried installation with apache 2.0.47. But nothing is working. Copied all
the dll's
and .ini file to the right locations. Changed the httpd.conf file as well.

Here is what I added in httpd.conf

LoadModule php4_module "c:/php/sapi/php4apache2.dll"
ScriptAlias /php4/ "C:/php"
AddType application/x-httpd-php4 .php"
Action application/x-httpd-php4 "php4/php.exe"
If you have PHP installed as a module, why are you passing PHP pages to
the CGI executor? And if you're going to do this, then the Action line
should read "/php4/php.exe".

Keep either the LoadModule and AddType lines (to use the module, which
is much better), or the ScriptAlias, AddType and Action lines (to use
CGI). Not both.
Start up apache is ok. But when I try to to this

<?php
phpinfo();
?>

in my index.html nothing is showed up.
You didn't mention any changes you made to httpd.conf that would make
Apache treat index.html as a PHP program. You can either do that or add
index.php to the DirectoryIndex line and use an index.php.
I also cannot browse .php files in my browser


Where are you putting them? In C:\PHP where they don't belong, or
someplace in your docroot?

--
Steve Koppelman
http://www.hatless.com/

Jul 17 '05 #2

P: n/a
If u can understand french, there is a customable tutorial at
http://giminik.developpez.com/apache/
Very easy to follow :) Good luck)
"Johan den Boer" <me@knoware.nl> a écrit dans le message de
news:vp************@corp.supernews.com...
Hi,

Tried installation with apache 2.0.47. But nothing is working. Copied all
the dll's
and .ini file to the right locations. Changed the httpd.conf file as well.

Here is what I added in httpd.conf

LoadModule php4_module "c:/php/sapi/php4apache2.dll"
ScriptAlias /php4/ "C:/php"
AddType application/x-httpd-php4 .php"
Action application/x-httpd-php4 "php4/php.exe"

Start up apache is ok. But when I try to to this

<?php
phpinfo();
?>

in my index.html nothing is showed up. I also cannot browse .php files in my browser

regards

Johan

Jul 17 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.