By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
455,045 Members | 1,139 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 455,045 IT Pros & Developers. It's quick & easy.

session start

P: n/a
I see this:
When I open a second browser window from the first (IE6), it uses the same session with first.
It have much fan to select "language1" (from "language2") in one window and in the next click second window be automatic
"language1".
But I want to eliminate this nasty effect.
How?

Thanks!
Jul 17 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
On Tue, 21 Oct 2003 23:45:22 +0300, "<- Chameleon ->"
<ch******@hotmail.NOSPAM.com> wrote:
I see this:
When I open a second browser window from the first (IE6), it uses the same session with first.
It have much fan to select "language1" (from "language2") in one window and in the next click second window be automatic
"language1".
But I want to eliminate this nasty effect.
How?

Thanks!


Hi Chameleon,

This is not true. What you are seeing is something to do with the
browser side, and cacheing. I never got to the bottom of it, but this
is true.

session_id is unique for each combination of browser/url.

( php 4.3.3 and apache 1/2/Netscape/iPlanet/SunONE servers )

Steve
Jul 17 '05 #2

P: n/a
> >When I open a second browser window from the first (IE6), it uses the same session with first.
It have much fan to select "language1" (from "language2") in one window and in the next click second window be automatic
"language1".
But I want to eliminate this nasty effect.


This is not true. What you are seeing is something to do with the
browser side, and cacheing. I never got to the bottom of it, but this
is true.
session_id is unique for each combination of browser/url.


I believe this too, but you can see:
1. try http://tassadar.physics.auth.gr/~chameleon/Books/
2. right-click in one menu link and "open in new window".
3. in 2nd browser window click greek flag
4. in 1st browser window click "Programming"
everything in 1st browser window are in greeks!!! (we activate greeks only in 2nd browser window)
I try Mozilla & IE6 too.

In the code, I have this for language:
language is changing with GET (eg index.php?lang=english)
if $lang is not set (GET) try SESSION
if $_SESSION['session_lang'] is not set try COOKIE
if $_COOKIE['cookie_lang'] is not set try language for domain (eg gr=greek it=italian fr=francais default=english)

What is error?

thanks
Jul 17 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.