467,879 Members | 1,237 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 467,879 developers. It's quick & easy.

compile and disable safe_mode

Hi all,

I've tried to compile PHP-4.3.3 for a HORDE installation and it
requires that PHP is compiled with safe_mode disabled. I compiled it
like this:

--disable-safe_mode
--enable-safe_mode=no
and omitted the line all together and still cannot get it to work
because when I run the test that comes with HORDE I still see that
safe_mode is not disabled. Any hints on what could be wrong?

Thanks in advance...

David
Jul 17 '05 #1
  • viewed: 2170
Share:
1 Reply
David Ruiz <fa**********@yahoo.com> wrote:
I've tried to compile PHP-4.3.3 for a HORDE installation and it
requires that PHP is compiled with safe_mode disabled. I compiled it
like this:

--disable-safe_mode
--enable-safe_mode=no
and omitted the line all together and still cannot get it to work
because when I run the test that comes with HORDE I still see that
safe_mode is not disabled. Any hints on what could be wrong?


Hi David,

You don't have to specify that at compile level - it's actually a runtime
directive in php.ini.

Put a php page with phpinfo() up and check whether it picks up a php.ini. If
not, copy the php.ini-dist in your source folder to where PHP expects it to
be and rename it php.ini. safe_mode should be off by default anyway, so it
might be a different problem altogether.

HTH;
JOn
Jul 17 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

1 post views Thread by Henrik Oddershede | last post: by
reply views Thread by Gerrit Kuilder | last post: by
1 post views Thread by Felix Natter | last post: by
1 post views Thread by David | last post: by
1 post views Thread by ramc18 | last post: by
reply views Thread by Zeilkman | last post: by
2 posts views Thread by akhilesh.noida | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.