By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
455,747 Members | 1,701 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 455,747 IT Pros & Developers. It's quick & easy.

Installing PHP4.3 on Windows XP

P: n/a
Erm, help, chaps!

I'm trying to get PHP 4.3 working on Windows XP with IIS as server.
Was able to make the CGI installation program go through its hoops
(which I've done on various platforms before now), but this one
isn't working properly. I think the problem is that it's
not communicating with the IIS server correctly.

I have

extension_dir = "c:\php"
enable_dl = off
cgi.force_redirect = 0

I don't have any of the php_* extensions set. Anything with
domain name is set to localhost.

IIS services seem to be working. I can bring up the Microsoft
help page, and so forth. I did set IIS to start on boot.



Jul 17 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a

"JimC" <ji**@cross-comp.com> wrote in message
news:pF*****************@newssvr27.news.prodigy.co m...
Erm, help, chaps!

I'm trying to get PHP 4.3 working on Windows XP with IIS as server.
Was able to make the CGI installation program go through its hoops
(which I've done on various platforms before now), but this one
isn't working properly. I think the problem is that it's
not communicating with the IIS server correctly.

I have

extension_dir = "c:\php"
enable_dl = off
cgi.force_redirect = 0

I don't have any of the php_* extensions set. Anything with
domain name is set to localhost.

IIS services seem to be working. I can bring up the Microsoft
help page, and so forth. I did set IIS to start on boot.


I figured out one way to solve this. (Again, the problem is to
make PHP work under IIS 5 on a Windows XP platform.)

Go to Control Panel and choose Computer Management. (Alternately,
click right on My Computer and then select Manage.

Under Internet Information Service, find Web Sites -> Default Web Site.
Click right on this tab. Select Properties. Select the Home Directory
tab. Select Configuration. You will add a file extension type. Select
ADD. In the executable window, add the path to php.exe, which
for many users will be in the c:\php subdirectory. For extension,
put ".php" (without quotes), and select All Verbs. Select OK to
save the addition. Either stop and start your IIS service, or reboot.

The usual test is to use the phpinfo() function. That is, use Notepad
to create a file, say phpinfo.php containing one line:

<? phpinfo(); ?>

and save this in the Inetpub\wwwroot directory. Open a browser
and enter the URL

http://localhost/phpinfo.php

and the PHP start page should come up.

HTH!
Jim


Jul 17 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.