By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
448,686 Members | 1,124 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 448,686 IT Pros & Developers. It's quick & easy.

make hangs on "libz.la" not found error

P: n/a
lee
Hello

I hope someone out there can help explain this to me.

This afternoon I successfully compiled php4.3.3 with a given set of
configuration options.

It then transpired that I had used incorrect versions of libxml and
libxslt on which to build the php. So I built newer versions of each.

I therefore needed to rebuild php again in order to take advantage of the
changes. I did a 'make distclean' and started from scratch.

I ran configure again using the same set of options.

This time 'make' fails at the following point:

"
grep: /usr/lib/libz.la:No such file or directory
/bin/sed: can't read /usr/lib/libz/la: No such file or directory
libtool: link: '/usr/lib/libz.la' is not a valid libtool archive
make: [libphp4.la] Error 1
"

It is true that I do not now have /usr/lib/libz.la but I have not changed
anything to do with zlib at all.

I also cannot find out which source would provide libz.la file, so I assume
that it is something that is generated locally.

I have tried deleting config.cache but this does not help. I have also
tried unzipping my php-4.3.3. source into a new directory and running
from there. Still the same error.

Any advice very gratefully received

Thank you

Lee
Jul 17 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.