By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
426,083 Members | 1,608 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 426,083 IT Pros & Developers. It's quick & easy.

phpMyAdmin 'cannot load mysql extension'

P: n/a
Hi,
when I try to open phpMyAdmin administration page I got this error:

'Cannot load mysql extension, please check your PHP configuration'

I cannot sort out what's the source of the problem, cause:
1. In the php.ini file I commented out the line
'extension=php_mysql.dll' and properly set the path to extension
directory: extension_dir = "c:\php\ext\"
2. MySQL is running
3. In the config.inc.php file I set $cfg['PmaAbsoluteUri'] to
http://localhost/phpMyAdmin/ and $cfg['servers'][$i]['extension'] to mysql
4. I tried also copying php_mysql.dll and libmysql.dll modules to system
folders: system i system32 but it didn't work.

I'm using following versions of software (under Windows XP):
PHP 5.0.5
phpMyAdmin 2.6.4-pl3
Apache 2.0.54
MySQL 5.0.15

I would much appreciate any help,
Renata
Nov 9 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
lithne wrote:
Hi,
when I try to open phpMyAdmin administration page I got this error:

'Cannot load mysql extension, please check your PHP configuration'

I cannot sort out what's the source of the problem, cause:
1. In the php.ini file I commented out the line
'extension=php_mysql.dll' and properly set the path to extension
directory: extension_dir = "c:\php\ext\"
2. MySQL is running
3. In the config.inc.php file I set $cfg['PmaAbsoluteUri'] to
http://localhost/phpMyAdmin/ and $cfg['servers'][$i]['extension'] to mysql
4. I tried also copying php_mysql.dll and libmysql.dll modules to system
folders: system i system32 but it didn't work.

I'm using following versions of software (under Windows XP):
PHP 5.0.5
phpMyAdmin 2.6.4-pl3
Apache 2.0.54
MySQL 5.0.15

I would much appreciate any help,
Renata

I had the same problem and did everything you described here, plus: I
donwloaded the full PHP package as a zip file and used the DLLs from
that package. That solved it. If it doesn't, it may be that there are
two PHP.INI files on your system (one in the systemfolder and one in the
PHP folder), and you may be editing the wrong one.

Good luck.
Nov 9 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.