By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
457,887 Members | 1,214 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 457,887 IT Pros & Developers. It's quick & easy.

Sorry..try this one...phpinfo and PHP predefined constants do NOT match!

P: n/a
Sorry for previous email...hit the wrong key!

Original Email:

I ran the following code:
<?php
$a=get_defined_constants();
foreach($a as $key=>$value){
echo "$key = $value<br/>";
}
?>

and got the following as part of my output:
......
PHP_EXTENSION_DIR = C:\php5
PHP_PREFIX = C:\php5
PHP_BINDIR = C:\php5
PHP_LIBDIR = C:\php5
PHP_DATADIR = C:\php5
PHP_SYSCONFDIR = C:\php5
PHP_LOCALSTATEDIR = C:\php5

But I don't HAVE a "C:\php5" folder. I have everything in a folder called
"C:\PHP"...and when I run phpinfo() it lists the "C:\PHP\..." folder names
for 'includes', 'extensions', etc.

This tells me that you can't depend on the predefined constants.

????????????????

Larry Woods
Aug 30 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
lwoods wrote:
Sorry for previous email...hit the wrong key!

Original Email:

I ran the following code:
<?php
$a=get_defined_constants();
foreach($a as $key=>$value){
echo "$key = $value<br/>";
}
?>

and got the following as part of my output:
.....
PHP_EXTENSION_DIR = C:\php5
PHP_PREFIX = C:\php5
PHP_BINDIR = C:\php5
PHP_LIBDIR = C:\php5
PHP_DATADIR = C:\php5
PHP_SYSCONFDIR = C:\php5
PHP_LOCALSTATEDIR = C:\php5

But I don't HAVE a "C:\php5" folder. I have everything in a folder called
"C:\PHP"...and when I run phpinfo() it lists the "C:\PHP\..." folder names
for 'includes', 'extensions', etc.

This tells me that you can't depend on the predefined constants.


Better report it to the PHP dev team via bugs.php.net and update the
status here.

--
<?php echo 'Just another PHP saint'; ?>
Email: rrjanbiah-at-Y!com Blog: http://rajeshanbiah.blogspot.com/

Sep 4 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.