471,306 Members | 953 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,306 software developers and data experts.

apache2.0.47 and php4.3.3 on slackware8.1

Hello all,

I am attempting to install Apache 2.0.47 and php4.3.3 on slackware8.1. I am
pretty new to linux and this is something of a learning experience and so I
was anticipating a few problems along the way. Now I have pretty much
followed the instructions at lamps.efactory.de/e-lamps-2-0.shtml word for
word, but when i try to access a simple php file (<?php phpinfo(); ?>) in
lynx it just shows me the source code (i.e. <?php phpinfo(); ?>). httpd is
definitely running. I have googled for this and there are lots of instances
of the problem, but no real answers.

I have installed apache from source, and it seems to run happily. I can see
the apache welcome page and there were no runtime or compile-time errors, so
I assume there is no problem there.

configure file was:

cd /usr/local/src/lamps/httpd-2.0.47/
../configure --prefix=/usr/local/apache2/2.0.47 \
--enable-modules=all \
--enable-ssl \
--with-ssl=/usr/local/openssl/current \
--enable-so
make
make install
I have also installed php from source, and again it seemed to compile fine.
The configure file was:

cd /usr/local/src/lamps/php-4.3.3
../configure \
--with-apxs2=/usr/local/apache2/current/bin/apxs \
--with-mysql=/usr/local/mysql/current \
--with-zlib-dir=/usr/lib/ \
--enable-versioning \
--enable-track-vars=yes \
--enable-url-includes \
--enable-sysvshm=yes \
--enable-sysvsem=yes \
--enable-ftp \
--with-config-file-path=/etc \
--with-gd
make
make install

and copied php.ini into /etc/

I have also added the appropriate lines into httpd.conf, namely

AddType application/x-httpd-php php
AddType application/x-httpd-php-source phps

and

LoadModule php4_module modules/libphp4.so
But no luck with php files, so any ideas? As I said I'm new to this so if
there are any other files that would be helpful in diagnosis just tell me
and I'll post them,

Thanks in advance,

Chris.
Jul 16 '05 #1
1 2147
In article <ba**************************@posting.google.com >,
ch**********@imperial.ac.uk says...
Hello all,

I am attempting to install Apache 2.0.47 and php4.3.3 on slackware8.1. I am
pretty new to linux and this is something of a learning experience and so I
was anticipating a few problems along the way. Now I have pretty much
followed the instructions at lamps.efactory.de/e-lamps-2-0.shtml word for
word, but when i try to access a simple php file (<?php phpinfo(); ?>) in
lynx it just shows me the source code (i.e. <?php phpinfo(); ?>). httpd is
definitely running. I have googled for this and there are lots of instances
of the problem, but no real answers.

I have installed apache from source, and it seems to run happily. I can see
the apache welcome page and there were no runtime or compile-time errors, so
I assume there is no problem there.

configure file was:

cd /usr/local/src/lamps/httpd-2.0.47/
./configure --prefix=/usr/local/apache2/2.0.47 \
--enable-modules=all \
--enable-ssl \
--with-ssl=/usr/local/openssl/current \
--enable-so
make
make install
I have also installed php from source, and again it seemed to compile fine.
The configure file was:

cd /usr/local/src/lamps/php-4.3.3
./configure \
--with-apxs2=/usr/local/apache2/current/bin/apxs \
--with-mysql=/usr/local/mysql/current \
--with-zlib-dir=/usr/lib/ \
--enable-versioning \
--enable-track-vars=yes \
--enable-url-includes \
--enable-sysvshm=yes \
--enable-sysvsem=yes \
--enable-ftp \
--with-config-file-path=/etc \
--with-gd
make
make install

and copied php.ini into /etc/

I have also added the appropriate lines into httpd.conf, namely

AddType application/x-httpd-php php
AddType application/x-httpd-php-source phps

and

LoadModule php4_module modules/libphp4.so
But no luck with php files, so any ideas? As I said I'm new to this so if
there are any other files that would be helpful in diagnosis just tell me
and I'll post them,


You need to restart apache to read any changes in httpd.conf, of course.

Cheers
--
Quod subigo farinam

$email =~ s/oz$/au/o;
A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?
A: Top-posting.
Q: What is the most annoying thing on usenet?
Jul 16 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

reply views Thread by Aldo Polli | last post: by
6 posts views Thread by Greg Bryant | last post: by
1 post views Thread by FL | last post: by
5 posts views Thread by Ad Astra | last post: by
3 posts views Thread by Martin Lucas-Smith | last post: by
1 post views Thread by news8080 | last post: by
3 posts views Thread by masterx | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.