By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
439,993 Members | 1,984 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 439,993 IT Pros & Developers. It's quick & easy.

DB::connect and PHP : hostname seems to be ignored ?!?!

P: n/a

Hello ,

a) in the following script (under RedHat AS3 with PHP 4.3.2 ) I make
a "DB::connect" to an existing "mysql" database named
"docu_files_of_cvdv" .

The strange thing is : it works -- even if I give as protocol the
string
"nonsenseprotocol" (instead of "unix" or "tcp") and as Hostname
"nonsensehostname" ... !!

Obviously PHP ignores the "protocol" and takes as Hostname the default
"localhost" .. ?!? I do NOT understand .. ! :
### here is the script :

#!/usr/bin/php
<?php
require("DB.php");
print("*** here PHPMYSQL.php *** \n");
print("*** now TRYING to connect .. *** \n");
$res =
DB::connect("mysql://nonsenseprotocol+nonsensehostname/docu_files_of_cvdv");
print("*** now having tried to connect .. *** \n");
if (DB::isError($res))
{
$str = $res->getMessage();
print("$str \n");
exit;
}
else
{
print("*** o.k. - result : $res *** \n");
print("*** now having done DB::connect -- successfully .. ?!?? *** \n");
}
exit;
?>

################

here is the result - having executed it :
Content-type: text/html
X-Powered-By: PHP/4.3.2
*** here PHPMYSQL.php ***
*** now TRYING to connect .. ***
*** now having tried to connect .. ***
*** o.k. - result : Object ***
*** now having done DB::connect -- successfully .. ?!?? ***
###########################################


b) HOW can I induce the PHP-Interpreter to EVALUATE the "protocol" and
"hostname" - Parameters in the "DB::connect"-string ?!

c) thanx for any hint :

Claus van de Vlierd

Jul 17 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
In article <3i************@news.dfncis.de>,
Claus van de Vlierd <cl*****************@uni-oldenburg.de> wrote:
Hello ,

a) in the following script (under RedHat AS3 with PHP 4.3.2 ) I make
a "DB::connect" to an existing "mysql" database named
"docu_files_of_cvdv" .

The strange thing is : it works -- even if I give as protocol the
string
"nonsenseprotocol" (instead of "unix" or "tcp") and as Hostname
"nonsensehostname" ... !!

Obviously PHP ignores the "protocol" and takes as Hostname the default
"localhost" .. ?!? I do NOT understand .. ! :
### here is the script :

#!/usr/bin/php
<?php
require("DB.php");
print("*** here PHPMYSQL.php *** \n");
print("*** now TRYING to connect .. *** \n");
$res =
DB::connect("mysql://nonsenseprotocol+nonsensehostname/docu_files_of_cvdv");
print("*** now having tried to connect .. *** \n");
if (DB::isError($res))
{
$str = $res->getMessage();
print("$str \n");
exit;
}
else
{
print("*** o.k. - result : $res *** \n");
print("*** now having done DB::connect -- successfully .. ?!?? *** \n");
}
exit;
?>

################

here is the result - having executed it :
Content-type: text/html
X-Powered-By: PHP/4.3.2
*** here PHPMYSQL.php ***
*** now TRYING to connect .. ***
*** now having tried to connect .. ***
*** o.k. - result : Object ***
*** now having done DB::connect -- successfully .. ?!?? ***
###########################################


b) HOW can I induce the PHP-Interpreter to EVALUATE the "protocol" and
"hostname" - Parameters in the "DB::connect"-string ?!

c) thanx for any hint :

Claus van de Vlierd

I think you want to look in DB.php to see what is going on. The PHP
Interpreter has nothing to do with this issue.
Jul 17 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.