By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
457,876 Members | 1,159 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 457,876 IT Pros & Developers. It's quick & easy.

phpinfo()

P: n/a
Hi
I am running Php5.0 on Windows XP. When I run phpinfo script it tells
me that the configuration file php.ini is located in C:\Windows. This
seems odd as I have put the PATH to php as D:\php where the php.ini
file is located.

Does anyone know how I can fix it so that the php.ini file comes up as
being in the D:\php folder not C:\Windows?

I am asking this question as I would like to get php5 and Mysql working
but they are not.

regards
Dominic

Jul 17 '05 #1
Share this Question
Share on Google+
10 Replies


P: n/a

<lo************@hotmail.com> wrote in message
news:11**********************@f14g2000cwb.googlegr oups.com...
Hi
I am running Php5.0 on Windows XP. When I run phpinfo script it tells
me that the configuration file php.ini is located in C:\Windows. This
seems odd as I have put the PATH to php as D:\php where the php.ini
file is located.

Does anyone know how I can fix it so that the php.ini file comes up as
being in the D:\php folder not C:\Windows?

I am asking this question as I would like to get php5 and Mysql working
but they are not.

regards
Dominic


php.ini needs to be in your windows directory.
Jul 17 '05 #2

P: n/a
Spidah said the following on 28/06/2005 01:24:
<lo************@hotmail.com> wrote in message
news:11**********************@f14g2000cwb.googlegr oups.com...
Hi
I am running Php5.0 on Windows XP. When I run phpinfo script it tells
me that the configuration file php.ini is located in C:\Windows. This
seems odd as I have put the PATH to php as D:\php where the php.ini
file is located.

Does anyone know how I can fix it so that the php.ini file comes up as
being in the D:\php folder not C:\Windows?

I am asking this question as I would like to get php5 and Mysql working
but they are not.


php.ini needs to be in your windows directory.

No it doesn't.

Read the manual:

http://www.php.net/manual/install.wi...apache2.module
--
Oli
Jul 17 '05 #3

P: n/a
> Does anyone know how I can fix it so that the php.ini file comes up as
being in the D:\php folder not C:\Windows?


Are you running the module or cgi?
What Server are you running (apache/IIS)?

-laidbak
Jul 17 '05 #4

P: n/a
lo************@hotmail.com wrote:
Hi
I am running Php5.0 on Windows XP. When I run phpinfo script it tells
me that the configuration file php.ini is located in C:\Windows. This
seems odd as I have put the PATH to php as D:\php where the php.ini
file is located.

Does anyone know how I can fix it so that the php.ini file comes up as
being in the D:\php folder not C:\Windows?

I am asking this question as I would like to get php5 and Mysql working
but they are not.

regards
Dominic

move the file from c:\windows into d:\php (has something to do with the
search order).
Jul 17 '05 #5

P: n/a
This is from php manual:

-------------------------
The default location of php.ini is a compile time option (see the FAQ
entry), but can be changed for the CGI and CLI version with the -c
command line switch, see the chapter about using PHP from the command
line. You can also use the environment variable PHPRC for an additional
path to search for a php.ini file.

--------------------------

.... By default PHP searchs php.ini in your Windows directory:

On Windows 9x/ME/XP copy your choosen ini file to your %WINDIR%, which
is typically c:\windows.
On Windows NT/2000 copy your choosen ini file to your %WINDIR% or
%SYSTEMROOT%, which is typically c:\winnt or c:\winnt40 for NT/2000
servers.

Jul 17 '05 #6

P: n/a
> Does anyone know how I can fix it so that the php.ini file comes up as
being in the D:\php folder not C:\Windows?


Remove php.ini from windows folder
Then add d:\php in the path variable
Create this registry enter:
[HKEY_LOCAL_MACHINE\SOFTWARE\PHP]
"IniFilePath"="D:\\PHP"

It should work in this mode ;)
Jul 17 '05 #7

P: n/a
I could not get the cgi to work and had to go with isapi?

Jul 17 '05 #8

P: n/a
Actually the php.ini file was never in the c:\windows directory but
always in the d:\php directory. Yet it showed up in the php.info as
being located in the c:\windows??

Jul 17 '05 #9

P: n/a
I will give it a try thanks.

Jul 17 '05 #10

P: n/a
I am running IIS and isapi. I could not get the cgi to work.

Jul 17 '05 #11

This discussion thread is closed

Replies have been disabled for this discussion.