By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
434,948 Members | 1,857 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 434,948 IT Pros & Developers. It's quick & easy.

Problem installing PHP on Apache server

P: n/a
Hi,

I am trying to install Apache and PHP. I have installed apache fine
where I can type in http://localhost and it displays the default Apache
page.

When trying to install PHP I have run the installer file which seemed
to go OK. It is when configure the Apache httpd.conf file that I get
the problem. I have updated the ScriptAlias to read:
ScriptAlias /php/ "C:/Program Files/PHP/"
And added the following lines:
Action application/x-httpd-php "/php/php.exe"
AddType application/x-httpd-php .php
...as instructed by the tutorial I was reading.

To test PHP, I have created a phpinfo() page called index.php inside
the htdocs folder in Apache. When I try to access the file it give the
following 404 error:
Not Found

The requested URL /php/php.exe/index.php was not found on this server.

Any ideas?

Cheers

Jul 17 '05 #1
Share this Question
Share on Google+
5 Replies


P: n/a
Yeah, install PHP as Apache module :-)

On 2005-06-08, bi******@yahoo.co.uk <bi******@yahoo.co.uk> wrote:

..as instructed by the tutorial I was reading.

Not Found

The requested URL /php/php.exe/index.php was not found on this server.
Any ideas?


--
Шушпанчики питаются исключительно кошерными желудями.
WBR, Дмитрий Лукашин
Jul 17 '05 #2

P: n/a
> Yeah, install PHP as Apache module :-)

Well, where have I gone wrong in doing this? When installing PHP I
selected Apache as the server software.

Jul 17 '05 #3

P: n/a
Am Wed, 08 Jun 2005 09:59:50 -0700 schrieb bissatch:
Hi,

I am trying to install Apache and PHP. I have installed apache fine
where I can type in http://localhost and it displays the default Apache
page.

When trying to install PHP I have run the installer file which seemed
to go OK. It is when configure the Apache httpd.conf file that I get
the problem. I have updated the ScriptAlias to read:
ScriptAlias /php/ "C:/Program Files/PHP/"
You do not need this alias here.


And added the following lines:
Action application/x-httpd-php "/php/php.exe"
Type here the real path to your php.exe i.e.:
Action application/x-httpd-php "C:/Program
Files/PHP/php.exe"
AddType application/x-httpd-php .php
..as instructed by the tutorial I was reading.

To test PHP, I have created a phpinfo() page called index.php inside the
htdocs folder in Apache. When I try to access the file it give the
following 404 error:
Not Found

The requested URL /php/php.exe/index.php was not found on this server.

Any ideas?

Cheers


--
-------------------------------------------------------
Try this: SCA the Smart Class Archive for PHP
http://www.project-sca.org
-------------------------------------------------------

Jul 17 '05 #4

P: n/a
Unzip the php into a folder called c:\php5

add these lines to your httpd.conf

LoadModule php5_module "c:/php5/php5apache2.dll"
AddType application/x-httpd-php .php
PHPIniDir "C:/php5"

copy all the *.dll files form php5 into the directory where apache.exe
is located or into the system32 directory.

uncomment any of the ;extension=* in your php.ini like php_mysql

change the extension_dir = to extension_dir = "c:\php5\ext\"

restart apache.

Jul 17 '05 #5

P: n/a
oh yea, remove the Action ... from httpd.conf

Jul 17 '05 #6

This discussion thread is closed

Replies have been disabled for this discussion.