471,354 Members | 2,129 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,354 software developers and data experts.

WIN2k+IIS5+CGI+ERROR

Hello Everyone.

I recently downloaded the PHP 4.3.2, I ran the installer, and did everything
accordingly, setting IIS4 or higher, all the right things ( I think ).
PHP is enabled as far as I know in IIS5 on all of my websites, but when ever
I try to load a php file from the web I get this exact error message.

"
CGI Error
The specified CGI application misbehaved by not returning a complete set of
HTTP headers. The headers it did return are:

"

Nothing returns after that either.
My file is called phpinfo.php. Although I can do a 4363473568546trgdfsh.php,
which does not even exists on our server, and the same error gets spit out.

I have looked on google, but I cannot figure this one out.
Could someone PLEASE help me solve this. As I am getting sick to death of
using ASP.

Thanks!
Jul 16 '05 #1
3 3498
Adam wrote:
Hello Everyone.

I recently downloaded the PHP 4.3.2, I ran the installer, and did everything
accordingly, setting IIS4 or higher, all the right things ( I think ).
PHP is enabled as far as I know in IIS5 on all of my websites, but when ever
I try to load a php file from the web I get this exact error message.

"
CGI Error
The specified CGI application misbehaved by not returning a complete set of
HTTP headers. The headers it did return are:

"

Nothing returns after that either.
My file is called phpinfo.php. Although I can do a 4363473568546trgdfsh.php,
which does not even exists on our server, and the same error gets spit out.
Prolly a permissions error. Take a look at the install.txt file you get
with PHP. There's some stuff there to try.
I have looked on google, but I cannot figure this one out.
Could someone PLEASE help me solve this. As I am getting sick to death of
using ASP.

Thanks!


--
MeerKat

Jul 16 '05 #2
Ok, everything is working now except when I try to perform a
header("Location : /path/file.php");

it produces that error.
Any new suggestions, everything PHP wise is working though, even got it
connecting to a msSQL database server.
Thanks guys!!

"Tom Thackrey" <to***@creative-light.com> wrote in message
news:O1****************@newssvr27.news.prodigy.com ...

On 25-Aug-2003, "Adam" <ad*****@sharklogic.com> wrote:
I recently downloaded the PHP 4.3.2, I ran the installer, and did
everything
accordingly, setting IIS4 or higher, all the right things ( I think ).
PHP is enabled as far as I know in IIS5 on all of my websites, but when
ever
I try to load a php file from the web I get this exact error message.

"
CGI Error
The specified CGI application misbehaved by not returning a complete set
of
HTTP headers. The headers it did return are:

"

Nothing returns after that either.
My file is called phpinfo.php. Although I can do a
4363473568546trgdfsh.php,
which does not even exists on our server, and the same error gets spit
out.

I have looked on google, but I cannot figure this one out.
Could someone PLEASE help me solve this. As I am getting sick to death of using ASP.

1) Try a .htm file from the same directory (to ensure you are actually
getting to that directory)
2) Verify your php file works on some other server. Or use a known good

..php file like:
<?php
phpinfo();
?>

--
Tom Thackrey
www.creative-light.com

Jul 16 '05 #3
Adam wrote:
Ok, everything is working now except when I try to perform a
header("Location : /path/file.php");

it produces that error.


That'll be the space after Location and before the colon. Incidentally,
the URL in a Location header should be the full URL:
header("Location: http://www.server.com/path/file.php");

--
MeerKat

Jul 16 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.