By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
454,409 Members | 1,604 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 454,409 IT Pros & Developers. It's quick & easy.

Mail's "from" getting reformatted

P: n/a
Hi all,

This may not be a PHP issue, but I was hoping someone might know where to
look. I have a web app that a client purchased which sends an email using
PHP's "mail" function. If it sends a message of the format:
js****@example.com <John Smith>, it arrives with a from line looking like
this:

From: js****@example.com Jo********@server.domain.com

Where the from name has gotten reformatted to look like an email address.
Where should I look for the cause of this? Is it sendmail.cf? PHP.ini?
Httpd.conf?

Thanks,
Kevin
Jul 17 '05 #1
Share this Question
Share on Google+
5 Replies


P: n/a
On Tue, 24 May 2005 09:44:23 -0400, Kevin wrote:
js****@example.com <John Smith>


Wrong way around. Try: John Smith <js****@example.com>
--
Firefox Web Browser - Rediscover the web - http://getffox.com/
Thunderbird E-mail and Newsgroups - http://gettbird.com/
Jul 17 '05 #2

P: n/a
On Tue, 24 May 2005 15:49:01 +0200, I wrote:
Wrong way around. Try: John Smith <js****@example.com>


Btw, enclose the name in double quotes if it contains other characters
than a-z: "J. Smith" <js****@example.com>
--
Firefox Web Browser - Rediscover the web - http://getffox.com/
Thunderbird E-mail and Newsgroups - http://gettbird.com/
Jul 17 '05 #3

P: n/a
*** Kevin wrote/escribió (Tue, 24 May 2005 09:44:23 -0400):
If it sends a message of the format:
js****@example.com <John Smith>, it arrives with a from line looking like
this:

From: js****@example.com Jo********@server.domain.com


Whatever you enclose in < > chars is treated as an e-mail address. When
mail servers find an address that is not a FQDN (fully-qualified domain
name) they consider it a local recipient and they normally autocomplete the
adress appending server's main domain name.

As Ewoud points you probably mean this:

"John Smith" <js****@example.com>
--
-- Álvaro G. Vicario - Burgos, Spain
-- http://bits.demogracia.com - Mi sitio sobre programación web
-- Don't e-mail me your questions, post them to the group
--
Jul 17 '05 #4

P: n/a
Thanks to both of you. That was it. Looks like the authors of the
application got their mail format backwards.

- Kevin

"Alvaro G Vicario" <al******************@telecomputeronline.com> wrote in
message news:7k****************************@40tude.net...
*** Kevin wrote/escribió (Tue, 24 May 2005 09:44:23 -0400):
If it sends a message of the format:
js****@example.com <John Smith>, it arrives with a from line looking like
this:

From: js****@example.com Jo********@server.domain.com


Whatever you enclose in < > chars is treated as an e-mail address. When
mail servers find an address that is not a FQDN (fully-qualified domain
name) they consider it a local recipient and they normally autocomplete
the
adress appending server's main domain name.

As Ewoud points you probably mean this:

"John Smith" <js****@example.com>
--
-- Álvaro G. Vicario - Burgos, Spain
-- http://bits.demogracia.com - Mi sitio sobre programación web
-- Don't e-mail me your questions, post them to the group
--

Jul 17 '05 #5

P: n/a
Ewoud Dronkert wrote:
On Tue, 24 May 2005 09:44:23 -0400, Kevin wrote:
js****@example.com <John Smith>


Wrong way around. Try: John Smith <js****@example.com>


It's also a good idea to put quotes around the name part eg

"John Smith" <js****@example.com>

--
Chris Hope | www.electrictoolbox.com | www.linuxcdmall.com
Jul 17 '05 #6

This discussion thread is closed

Replies have been disabled for this discussion.