By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
443,983 Members | 1,627 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 443,983 IT Pros & Developers. It's quick & easy.

PHP under IIS : extension_dir problem

P: n/a
Dear All,
I'm having LOTS of troubles setting the extensions directory under windows.

On my "testing" server (windows XP, IIS), I could set the directory to :

extension_dir = ./extensions/

That's it, no quotes and slashes.

On the "prod" server (Win NT 4 + IIS), there's no way to make it work...
I've tried this relative path, an absolute path, slashes and
backslashes, quotes or no quotes. Everytime I restarted IIS.

Every time, I get a message "unable to load extension
d:\intranet\php\extensions\php_gd2.dll". Yes the file is there at this
exact path.

Any idea ? Comments in the documentation did not help this time :(

Thanks a lot in advance !
--
Damien

"All parts should go together without forcing. You must remember that
the parts you are reassembling were disassembled by you. Therefore, if
you can't get them together again, there must be a reason. By all means,
do not use hammer." -- IBM maintenance manual, 1975
Jul 17 '05 #1
Share this Question
Share on Google+
6 Replies


P: n/a
NC
Damien wrote:

Every time, I get a message "unable to load extension
d:\intranet\php\extensions\php_gd2.dll". Yes the file is there at this exact path.


Try another extension library. If it works, your copy of php_gd2.dll
is damaged. Replace it and try again. If it doesn't, check
permissions
on the extensions directory.

Also, check if your version of PHP is compatible with GD 2.

Cheers,
NC

Jul 17 '05 #2

P: n/a
NC a écrit :
(snip)
Try another extension library. Did so, no luck.
If it works, your copy of php_gd2.dll
is damaged. Replace it and try again.
No other extension seems to work : mbstrings, pdf, zip...
If it doesn't, check
permissions on the extensions directory.
Good point.
Also, check if your version of PHP is compatible with GD 2.

Another good point, I'll go and check if 4.3.7 is compatible.

Yet, I've just checked my "home" windows xp:
extension_dir = "c:\php\extensions\"

Not the same as the one at work :'(

Thanks again !
Cheers,
--
Damien
Jul 17 '05 #3

P: n/a
You're sure it's not a permissions issue? (Not that I know how
permissions work on Windows and/or IIS...)

Jul 17 '05 #4

P: n/a
May I ask why anyone would put themselves through the pain and torture of
using PHP on IIS rather than Apache?

ECRIA
http://www.ecria.com
Jul 17 '05 #5

P: n/a
NC
ECRIA Public Mail Buffer wrote:

May I ask why anyone would put themselves through the pain and torture
of using PHP on IIS rather than Apache?


Last few times I set up PHP under IIS, I didn't notice pain nor
torture... :) Seriously, though, the reason is very simple; you
may need to host PHP applications and ASP applications on the same
machine.

Cheers,
NC

Jul 17 '05 #6

P: n/a
On Tue, 24 May 2005 15:39:43 -0400, ECRIA Public Mail Buffer wrote:
May I ask why anyone would put themselves through the pain and torture of
using PHP on IIS rather than Apache?


Because some ISPs insist on running Winblows boxes and some clients
insist on retaining their current ISP. As a developer, I'm not always
able to control that ... only advise, or suggest.

I've come across this situation a few times. That they're even
prepared to install PHP at all is a blessing!

Apache on Win32 isn't stable enough for a production environment
(according to Apache). The good news is that I think PHP is helping to
make inroads into the MS monolith, and ISPs that were previously tied
to MS-only solutions are now seriously looking at Linux alternatives.

Adam.
Jul 17 '05 #7

This discussion thread is closed

Replies have been disabled for this discussion.