By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
454,406 Members | 1,537 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 454,406 IT Pros & Developers. It's quick & easy.

Incorrect path order for php.ini

P: n/a
I'm running PHP 4.3.11 on Windows 2003/IIS in CGI mode.

My understanding is that PHP should search for the php.ini first
according to the registry value:
HKEY_LOCAL_MACHINE\SOFTWARE\PHP\IniFilePath (which is empty on my
machine);

Then according to the environmental value:
PHPRC (also empty on my machine);

Then the local directory:
D:\php-4.3.11\ for me

Finally the system root:
C:\winnt\ for me

The problem I'm having is that it's first finding the one in the system
root folder and using it (verified using phpinfo()). If I rename that
one, it will find the one in the local CGI folder and use it just fine
(so it's not a permissions issue).

I need to keep the file in the system root folder (for php5 ISAPI) but
I need php 4 to find it's local file. I've copied the php4
configuration to a different machine and it behaved how it should, so
the problem is specific to the machine. Does anybody have any
suggestions?

Thanks

Jul 17 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.