By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
454,407 Members | 1,473 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 454,407 IT Pros & Developers. It's quick & easy.

PHP Output limit 2M?

P: n/a
Hi,

I'm using fpassthru() to send files to the browser, but only the first
2000000 bytes are sent. The apache log shows 2000000 bytes too.

Where does this limit come from and how do I change it?

My system:

PHP5.04
Apache/2.0.49 (Linux/SuSE)

I am using no output handler, and I have tried turning output buffering on
and off. I have set memory limit to 32Mb. None of that helps.

Best Regards,

Peter Albertsson
Jul 17 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
"Peter Albertsson" <Pe***********************@antispOm.comhem.se> wrote in
message news:iy*********************@newsc.telia.net...
Hi,

I'm using fpassthru() to send files to the browser, but only the first
2000000 bytes are sent. The apache log shows 2000000 bytes too.

Where does this limit come from and how do I change it?

My system:

PHP5.04
Apache/2.0.49 (Linux/SuSE)

I am using no output handler, and I have tried turning output buffering on
and off. I have set memory limit to 32Mb. None of that helps.

Best Regards,

Peter Albertsson


I found the problem, it's a bug in PHP5.04...
http://bugs.php.net/bug.php?id=32553)
Jul 17 '05 #2

P: n/a

"Peter Albertsson" <Pe***********************@antispOm.comhem.se> wrote in
message news:vN*********************@newsc.telia.net...
"Peter Albertsson" <Pe***********************@antispOm.comhem.se> wrote in
message news:iy*********************@newsc.telia.net...
Hi,

I'm using fpassthru() to send files to the browser, but only the first
2000000 bytes are sent. The apache log shows 2000000 bytes too.

Where does this limit come from and how do I change it?

My system:

PHP5.04
Apache/2.0.49 (Linux/SuSE)

I am using no output handler, and I have tried turning output buffering
on and off. I have set memory limit to 32Mb. None of that helps.

Best Regards,

Peter Albertsson


I found the problem, it's a bug in PHP5.04...
http://bugs.php.net/bug.php?id=32553)


And here is the patch:
https://bugzilla.redhat.com/bugzilla....cgi?id=155916
https://bugzilla.redhat.com/bugzilla....cgi?id=113644

Best Regards,

Peter Albertsson
Jul 17 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.