469,330 Members | 1,326 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,330 developers. It's quick & easy.

How to access phpMyAdmin from local and from Internet

I've just installed phpMyAdmin.

If I have the line
$cfg['PmaAbsoluteUri'] = 'http://localhost/php/phpmyadmin';
in my config.inc.php I can login to phpMyAdmin without any problems from my
local machine. But it's not working from the Internet.

To access it from the Internet I have modify the line
$cfg['PmaAbsoluteUri'] = 'http://www.myserver.com/php/phpmyadmin';

But now I'm not able to access it from the local machine.

Is there any solution for my problem?
Stefan
Jul 17 '05 #1
4 35957
On Fri, 15 Apr 2005 18:00:07 +0200, "Stefan Mueller"
<se**************@yahoo.com> wrote:
I've just installed phpMyAdmin.

If I have the line
$cfg['PmaAbsoluteUri'] = 'http://localhost/php/phpmyadmin';
in my config.inc.php I can login to phpMyAdmin without any problems from my
local machine. But it's not working from the Internet.


The comment line says...

* In most cases you can leave this variable empty, as the correct
value
* will be detected automatically.

Look further down in 'config.inc.php' and you'll see several blocks to
populate the $cfg['servers'] array. If you fill in the values for both
your servers, phpMyAdmin will prompt you to choose server.

Paul Brooks
Jul 17 '05 #2
"Stefan Mueller" <se**************@yahoo.com> wrote in
news:3c*************@uni-berlin.de:
I've just installed phpMyAdmin.

If I have the line
$cfg['PmaAbsoluteUri'] = 'http://localhost/php/phpmyadmin';
in my config.inc.php I can login to phpMyAdmin without any problems
from my local machine. But it's not working from the Internet.

To access it from the Internet I have modify the line
$cfg['PmaAbsoluteUri'] = 'http://www.myserver.com/php/phpmyadmin';

But now I'm not able to access it from the local machine.


If you cannot access an internet address from your local PC, it has a
problem with it's setup. Maybe incorrect DNS? A quick easy fix for
that one hostname is to put the server name/IP in your hosts file, but
if you can't access an internet address, you may have a bigger problem
on that machine. Can you access other internet addresses?

--
Stan McCann "Uncle Pirate" http://stanmccann.us/pirate.html
Webmaster/Computer Center Manager, NMSU at Alamogordo
Coordinator, Tularosa Basin Chapter, ABATE of NM; AMA#758681; COBB
'94 1500 Vulcan (now wrecked) :( http://motorcyclefun.org/Dcp_2068c.jpg
A zest for living must include a willingness to die. - R.A. Heinlein
Jul 17 '05 #3
Yes, you're right. The behavior of my network is somehow strange, but I
can't change it.
If I do a connection from my internal network to an internet address the
traffic goes to my ZyXEL H650i (ADSL Router) and from there to the internet.
Everything works fine.
If you do a connection from the internet to my server with
http://www.myserver.com/php/phpmyadmin
the traffic also goes to my ZyXEL H650i and is NATted there to my internal
server address.
If I do this connection from my internal network the traffic also goes to my
ZyXEL H650i but is not NATted there to my internal server address.
It seems that my ZyXEL H650i can only do NAT for traffic comming from the
internet to my internal network and not if the traffic is comming from the
LAN side with a WAN address.

Stefan

"Uncle Pirate" <Un*********@stanmccann.us> wrote in message
news:Xn**********************************@216.234. 192.142...
"Stefan Mueller" <se**************@yahoo.com> wrote in
news:3c*************@uni-berlin.de:
I've just installed phpMyAdmin.

If I have the line
$cfg['PmaAbsoluteUri'] = 'http://localhost/php/phpmyadmin';
in my config.inc.php I can login to phpMyAdmin without any problems
from my local machine. But it's not working from the Internet.

To access it from the Internet I have modify the line
$cfg['PmaAbsoluteUri'] = 'http://www.myserver.com/php/phpmyadmin';

But now I'm not able to access it from the local machine.


If you cannot access an internet address from your local PC, it has a
problem with it's setup. Maybe incorrect DNS? A quick easy fix for
that one hostname is to put the server name/IP in your hosts file, but
if you can't access an internet address, you may have a bigger problem
on that machine. Can you access other internet addresses?

--
Stan McCann "Uncle Pirate" http://stanmccann.us/pirate.html
Webmaster/Computer Center Manager, NMSU at Alamogordo
Coordinator, Tularosa Basin Chapter, ABATE of NM; AMA#758681; COBB
'94 1500 Vulcan (now wrecked) :( http://motorcyclefun.org/Dcp_2068c.jpg
A zest for living must include a willingness to die. - R.A. Heinlein

Jul 17 '05 #4

On Tue, 19 Apr 2005 23:00:57 +0200, "Stefan Mueller"
<se**************@yahoo.com> wrote:

( Better late than never )
Yes, you're right. The behavior of my network is somehow strange, but I
can't change it.
If I do a connection from my internal network to an internet address the
traffic goes to my ZyXEL H650i (ADSL Router) and from there to the internet.
Everything works fine.
If you do a connection from the internet to my server with
http://www.myserver.com/php/phpmyadmin
the traffic also goes to my ZyXEL H650i and is NATted there to my internal
server address.
If I do this connection from my internal network the traffic also goes to my
ZyXEL H650i but is not NATted there to my internal server address.
It seems that my ZyXEL H650i can only do NAT for traffic comming from the
internet to my internal network and not if the traffic is comming from the
LAN side with a WAN address.
Try:
ip nat loopback on

If it works, try to insert it in the startup script of the
router, so the command will be executed at every power up and
reset:

sys edit autoexec.net
i (=Insert)
<enter> until you see: wan adsl ...etc
ip nat loopback on<enter>
x (=exit and save)
Stefan


Should work on that ZyXEL ..
--
) Kees Nuyt
(
c[_]
Sep 24 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

5 posts views Thread by John Lauwers | last post: by
reply views Thread by Steffen | last post: by
reply views Thread by suresh191 | last post: by
reply views Thread by Purva khokhar | last post: by
reply views Thread by haryvincent176 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.