By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
459,567 Members | 1,670 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 459,567 IT Pros & Developers. It's quick & easy.

PHP 5.0.3 & MySQL 4.1

P: n/a
Okay..hope someone out there knows the answer to this. Anyhow, I've
install PHP 5.0.3 and mySQL 4.1 but problem is that PHP 5 isn't
taking/or doesn't have..I really got no idea the MySQL Extension. did
phpinfo() and its not listed in there so I know its nowhere to found.
So I reintall my php manytimes and MySQL but nothing. No help.

Now for info, I'm using Apache 2.0 on Windows XP Pro. All server stuff
including Apache is on its own drive, not C! Rather F, if anyone wishes
to know. Also PHP is install as an Apache module. That's basically
about it...

Can't get PHP 5 to say hi MySQL welcome you are an extension lets use
you! enjoy!! :-/ anyone know how...

Jul 17 '05 #1
Share this Question
Share on Google+
5 Replies


P: n/a
On 2005-03-25, Travis Font <tr*********@gmail.com> wrote:
Okay..hope someone out there knows the answer to this. Anyhow, I've
install PHP 5.0.3 and mySQL 4.1 but problem is that PHP 5 isn't
taking/or doesn't have..I really got no idea the MySQL Extension. did
phpinfo() and its not listed in there so I know its nowhere to found.
So I reintall my php manytimes and MySQL but nothing. No help.


so you might want to read the documentation on how to enable an
extension. in case you got the php-zip package it's only a matter of
removing the ; before extension=php_mysqli.dll in your php.ini
and restarting apache...
--
Met vriendelijke groeten,
Tim Van Wassenhove <http://www.timvw.info>
Jul 17 '05 #2

P: n/a
been pass that and nothing. if remove the ; in php.ini to load the dll
once i restart apache it errors and says it can be founded.

Jul 17 '05 #3

P: n/a
This means that while trying to load the PHP extension it has failed to find
another DLL file. I am running XP Pro, Apache 2.0.53, PHP 5 and MySQL
4.1.10, so I had the same problem. You must copy libmysqli.dll to your
c:/windows/system folder, enable the mysqli extension, then restart Apache.

HTH.

--
Tony Marston

http://www.tonymarston.net

"Travis Font" <tr*********@gmail.com> wrote in message
news:11**********************@f14g2000cwb.googlegr oups.com...
been pass that and nothing. if remove the ; in php.ini to load the dll
once i restart apache it errors and says it can be founded.

Jul 17 '05 #4

P: n/a
Travis Font wrote:
Okay..hope someone out there knows the answer to this. Anyhow, I've
install PHP 5.0.3 and mySQL 4.1 but problem is that PHP 5 isn't
taking/or doesn't have..I really got no idea the MySQL Extension. did
phpinfo() and its not listed in there so I know its nowhere to found.
So I reintall my php manytimes and MySQL but nothing. No help.

Now for info, I'm using Apache 2.0 on Windows XP Pro. All server stuff
including Apache is on its own drive, not C! Rather F, if anyone wishes
to know. Also PHP is install as an Apache module. That's basically
about it...

Can't get PHP 5 to say hi MySQL welcome you are an extension lets use
you! enjoy!! :-/ anyone know how...


copy the libmysql.dll into the apache\bin folder and you're set!
Jul 17 '05 #5

P: n/a
On Sat, 26 Mar 2005 12:22:24 +0100, Bert Melis
<bert.melis@offsite_remove_this_.be> wrote:
copy the libmysql.dll into the apache\bin folder and you're set!


Or add the directory containing libmysql.dll to the PATH environment variable
- this works with servers other than Apache, and should make it less likely to
cause problems due to forgetting there's a DLL been moved around when
upgrading.

--
Andy Hassall / <an**@andyh.co.uk> / <http://www.andyh.co.uk>
<http://www.andyhsoftware.co.uk/space> Space: disk usage analysis tool
Jul 17 '05 #6

This discussion thread is closed

Replies have been disabled for this discussion.