By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
429,384 Members | 671 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 429,384 IT Pros & Developers. It's quick & easy.

PHP4 + PHP5 + ZendStudio

P: n/a

I've had setup on WinXP: Apache1.3 with PHP4 module and PHP5 installedas
CGI for one vhost.
This worked fine, till I installed Zend Studio 4 beta.

I'm trying to make Zend Server use my existing configuration, but without
success.
If I point it to PHP4 php.ini, PHP cannot find (or rather refuses to
load) modules.
If I point it to PHP5 php.ini, I cannot enter server console, because my
php lacks ZendOptimizer
(even if I install ZendOptimizer).

[Zend docs are brief, and googling finds only obvious answers,
like "install mysql and uncomment mysql extension".]

Do you have any suggestions how to get this trio working?

--
* html {redirect-to: url(http://browsehappy.pl);}
Jul 17 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
On Sun, 16 Jan 2005 12:29:08 -0000, porneL <po****@despammed.com>
wrote:
I've had setup on WinXP: Apache1.3 with PHP4 module and PHP5 installed as
CGI for one vhost.
This worked fine, till I installed Zend Studio 4 beta.


Do you have the latest versions of PHP4 and PHP5 installed? I had
problems with Zend Studio not working properly at all with PHP4 until
I installed the latest version.

I run both PHP4 and PHP5 but not together at once; I have a batch file
that converts my environment from one to the other depending on what I
need to work in. Both are thus installed as a module and the
locations of server component are always the same.

It's possible the install has completely buggered your configuration.
It changes both your Apache configuration and your PHP.INI file. I
suggest saving the old files and then undoing the changes and see if
you can't get everything working again. Then put in the Zend Studio
configuration items as they make sense to do. I had to do this and
now I'm working just fine.

Jul 17 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.