473,581 Members | 2,506 Online
Bytes | Software Development & Data Engineering Community
+ Post

Home Posts Topics Members FAQ

Configuring PHP 5.2.0 with Postgres 8.1.3 (no source)

I'm trying to configure PHP 5.2.0 with support for Postgres
8.1.3. Postgres was installed with FC5 without source. PHP's configure
needs source. When I run configure:

configure: error: Cannot find libpq-fe.h. Please specify
correct PostgreSQL installation path

I tried downloading Postgres source and modifying PHPs configure to
point to it, and that worked. But then compilation failed, e.g.

In file included from /home/jao/php-5.2.0/ext/pgsql/php_pgsql.h:32,
from /home/jao/php-5.2.0/ext/pgsql/pgsql.c:45:
/usr/local/src/postgresql-8.1.4/src/interfaces/libpq/libpq-fe.h:29:26:
error: postgres_ext.h: No such file or directory
In file included from /home/jao/php-5.2.0/ext/pgsql/php_pgsql.h:32,
from /home/jao/php-5.2.0/ext/pgsql/pgsql.c:45:
/usr/local/src/postgresql-8.1.4/src/interfaces/libpq/libpq-fe.h:317:
error: expected ';', ',' or ')' before '*' token

Then I thought I'd uninstall the postgres RPMs and build postgres from
scratch, but there are dependencies on postgres:

libpq.so.4 is needed by (installed) apr-util-1.2.2-4.2.i386
libpq.so.4 is needed by (installed) dovecot-1.0-0.beta2.7.i386
libpq.so.4 is needed by (installed) perl-DBD-Pg-1.43-2.2.2.i386

And I really don't want to unravel my entire set of RPMs.
So I have two questions:

1) Does PHP 5.2.0 support Postgres 8.x? The compilation errors, and
some of the postgres paths in the configure file suggest that it might
not.

2) How can I get PHP configured to support postgres?
Jack Orenstein

Dec 3 '06 #1
1 3856
On Sun, 03 Dec 2006 01:57:10 -0500, Jack Orenstein wrote:
So I have two questions:

1) Does PHP 5.2.0 support Postgres 8.x? The compilation errors, and
some of the postgres paths in the configure file suggest that it might
not.
It does.
2) How can I get PHP configured to support postgres?
Install the postgresql-devel RPM, run "make clean" in your PHP source,
then ./configure and make again.

Adam

--
Adam Harvey

To e-mail: don't make an example out of me!

Dec 4 '06 #2

This thread has been closed and replies have been disabled. Please start a new discussion.

Similar topics

0
2169
by: Adam Kempa | last post by:
Hello I've been installed Postgres 7.4.2 on FreeBSD system and when load average grow up i've error in postgres like this: ERROR: permission denied for function varchar ERROR: permission denied for function varchar and then postgres crashes. LOG: server process (PID 9787) was terminated by signal 11
2
2836
by: Maniek | last post by:
Hi, I have: (WinXP+SP2+MSSQL2k+Postgres 8.0.2) I'm trying to link the PostgreSQL 8.0.2 server in Enterprise Manager Tree and don't know some of the parameters. Has someone of you a Postgres server linked to MSSQL? Could you tell me, what data you have, please? Security / Linked Servers / New Linked Server...
3
4175
by: N.K. | last post by:
Hi, I've just installed postgres on the Linux server. It is supposed to start automatically which I think it does since I can run an sql stmt right away. When I'm trying to connect from a remote machine I get a message that the remote machine IP address is not specified in pg_hba.conf, that there is no record of that machine there....
5
5000
by: Alex Page | last post by:
I've been trying to extend Postgres and create an enumerated type to represent gender, as a precursor to more complex enumerated types. I've created the C functions for input and output with the following code: - ---- gender.c ----- #include "server/postgres.h" #include <string.h> #include "server/fmgr.h" ...
3
1798
by: Darkcamel | last post by:
Hello all, I am new to postgres and don't really understand how the database is set-up. I am very fluent with mysql and sql2000, but postgres is new to me. If anyone can point me to some good links I would appreciate it very much. Thanks, Darkcamel
1
3466
by: Liu, Mingyi | last post by:
Sorry if this question has been asked before. I tried to search in postgres mailing lists at http://archives.postgresql.org/pgsql-general/ just now and it gave me error "An error occured! Can not connect to search daemon". Anyway I installed tsearch2 and openFTS and was able to do some searches. However, when I checked searching partial...
0
2692
by: NM | last post by:
Hello, I've got a problem inserting binary objects into the postgres database. I have binary objects (e.g. images or smth else) of any size which I want to insert into the database. Funny is it works for files larger than 8000 Bytes. If a file is less than 1000 Bytes I get the following message: Error message: --invalid input syntax for...
1
2604
by: rada.lambretha | last post by:
Configuring Linux as a Firewall * Making installation choices * Introducing iptables * Using iptables commands * Simplifying things with firewall GUIs * Adding proxy functionality As Linux gains increasing acceptance in corporate datacenters and
0
2293
by: rski | last post by:
Does anyone of you Experts try to change postgres source code so that it would be available to perform the undelete command (restore deleted rows when no vacumm was called)?
0
7857
marktang
by: marktang | last post by:
ONU (Optical Network Unit) is one of the key components for providing high-speed Internet services. Its primary function is to act as an endpoint device located at the user's premises. However, people are often confused as to whether an ONU can Work As a Router. In this blog post, we’ll explore What is ONU, What Is Router, ONU & Router’s main...
0
7788
by: Hystou | last post by:
Most computers default to English, but sometimes we require a different language, especially when relocating. Forgot to request a specific language before your computer shipped? No problem! You can effortlessly switch the default language on Windows 10 without reinstalling. I'll walk you through it. First, let's disable language...
1
7890
by: Hystou | last post by:
Overview: Windows 11 and 10 have less user interface control over operating system update behaviour than previous versions of Windows. In Windows 11 and 10, there is no way to turn off the Windows Update option using the Control Panel or Settings app; it automatically checks for updates and installs any it finds, whether you like it or not. For...
0
8163
tracyyun
by: tracyyun | last post by:
Dear forum friends, With the development of smart home technology, a variety of wireless communication protocols have appeared on the market, such as Zigbee, Z-Wave, Wi-Fi, Bluetooth, etc. Each protocol has its own unique characteristics and advantages, but as a user who is planning to build a smart home system, I am a bit confused by the...
0
6545
agi2029
by: agi2029 | last post by:
Let's talk about the concept of autonomous AI software engineers and no-code agents. These AIs are designed to manage the entire lifecycle of a software development project—planning, coding, testing, and deployment—without human intervention. Imagine an AI that can take a project description, break it down, write the code, debug it, and then...
0
5355
by: conductexam | last post by:
I have .net C# application in which I am extracting data from word file and save it in database particularly. To store word all data as it is I am converting the whole word file firstly in HTML and then checking html paragraph one by one. At the time of converting from word file to html my equations which are in the word document file was convert...
0
3799
by: TSSRALBI | last post by:
Hello I'm a network technician in training and I need your help. I am currently learning how to create and manage the different types of VPNs and I have a question about LAN-to-LAN VPNs. The last exercise I practiced was to create a LAN-to-LAN VPN between two Pfsense firewalls, by using IPSEC protocols. I succeeded, with both firewalls in...
0
3813
by: adsilva | last post by:
A Windows Forms form does not have the event Unload, like VB6. What one acts like?
0
1127
bsmnconsultancy
by: bsmnconsultancy | last post by:
In today's digital era, a well-designed website is crucial for businesses looking to succeed. Whether you're a small business owner or a large corporation in Toronto, having a strong online presence can significantly impact your brand's success. BSMN Consultancy, a leader in Website Development in Toronto offers valuable insights into creating...

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.