473,840 Members | 1,578 Online
Bytes | Software Development & Data Engineering Community
+ Post

Home Posts Topics Members FAQ

error_reporting (E_ALL) fails to show anything - help!!

I am having problems tracing errors in my code using PHP 4.3.9 on Linux
RHEL 4 with Apache 2.0.54

On occasions I see no errors, no parse, no fatal, no warnings, no
notices.. and no code either! No HTML, nothing! I get a completely
blank page with no content whatsoever.

I have at the very top of my page
[PHP]
error_reporting (E_ALL);
[/PHP]

As a test to see if even notices would pop up, but nothing.

What could cause this to happen?

Thanx
Phil

Feb 1 '06 #1
9 2656
>I am having problems tracing errors in my code using PHP 4.3.9 on Linux
RHEL 4 with Apache 2.0.54

On occasions I see no errors, no parse, no fatal, no warnings, no
notices.. and no code either! No HTML, nothing! I get a completely
blank page with no content whatsoever.

I have at the very top of my page
[PHP]
error_reportin g(E_ALL);
[/PHP]


My bet is that you have at least:
[PHP]
<?php
error_reporting (E_ALL);
?>
[/PHP]

rather than what you indicated above.

Gordon L. Burditt
Feb 1 '06 #2

Gordon Burditt wrote:
I am having problems tracing errors in my code using PHP 4.3.9 on Linux
RHEL 4 with Apache 2.0.54

On occasions I see no errors, no parse, no fatal, no warnings, no
notices.. and no code either! No HTML, nothing! I get a completely
blank page with no content whatsoever.

I have at the very top of my page
[PHP]
error_reportin g(E_ALL);
[/PHP]
My bet is that you have at least:
[PHP]
<?php
error_reporting (E_ALL);
?>
[/PHP]

rather than what you indicated above.


That sounds redundant to me, unclear as to how this will shed light on
my problem.
Phil
Gordon L. Burditt


Feb 1 '06 #3
comp.lang.php wrote:
I am having problems tracing errors in my code using PHP 4.3.9 on Linux
RHEL 4 with Apache 2.0.54

On occasions I see no errors, no parse, no fatal, no warnings, no
notices.. and no code either! No HTML, nothing! I get a completely
blank page with no content whatsoever.

I have at the very top of my page
[PHP]
error_reporting (E_ALL);
[/PHP]

As a test to see if even notices would pop up, but nothing.

What could cause this to happen?

Thanx
Phil


check to see what the log_errors value is set to in php.ini... if it is
1, then you have to check your error.log file rather than the browser.

--
Justin Koivisto, ZCE - ju****@koivi.co m
http://koivi.com
Feb 1 '06 #4
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

comp.lang.php wrote:
I am having problems tracing errors in my code using PHP 4.3.9 on Linux
RHEL 4 with Apache 2.0.54


Can you run PHP on a CLI in that machine? That would clear things up.

Try:

echo "<?php phpinfo(); ?> " | /usr/bin/php

- --
- ----------------------------------
Iván Sánchez Ortega -i-punto-sanchez--arroba-mirame-punto-net

Un ordenador no es un televisor ni un microondas, es una herramienta
compleja.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)

iD8DBQFD4UoN3jc Q2mg3Pc8RAlqEAJ 4iEZGJr7UxpcRF1 Yq5c+A9E2uYFACc CPNe
IV8RwjNjUvne2+G EEL21iNg=
=H1cH
-----END PGP SIGNATURE-----
Feb 2 '06 #5
If error_reporting is set to 0 in php.ini, you won't see any E_PARSE
error message even if you do an error_reporting (E_ALL), as the error
would occur prior to the line being executed.

Feb 2 '06 #6
Iván Sánchez Ortega wrote:
comp.lang.php wrote:
I am having problems tracing errors in my code using PHP 4.3.9 on Linux
RHEL 4 with Apache 2.0.54


Can you run PHP on a CLI in that machine? That would clear things up.

Try:

echo "<?php phpinfo(); ?> " | /usr/bin/php


The CLI and the Apache module may have different configurations.

In my setup, they do

The Apache module
~$ wget http://localhost/info.php -O- 2> /dev/null | grep error_log
<tr><td class="e">error _log</td><td
class="v">/var/www/log/phperrors.log</td><td
class="v">/var/www/log/phperrors.log</td></tr>

This last line, reformatted, becomes
error_log => /var/www/log/phperrors.log => /var/www/log/phperrors.log

The CLI
~$ php /var/www/normal/info.php | grep error_log
error_log => no value => no value

--
If you're posting through Google read <http://cfaj.freeshell. org/google>
Feb 2 '06 #7
Justin Koivisto wrote:
comp.lang.php wrote:
On occasions I see no errors, no parse, no fatal, no warnings, no
notices.. and no code either! No HTML, nothing! I get a completely
blank page with no content whatsoever.

I have at the very top of my page
[PHP]
error_reporting (E_ALL);
[/PHP]

As a test to see if even notices would pop up, but nothing.


check to see what the log_errors value is set to in php.ini... if it is
1, then you have to check your error.log file rather than the browser.


If you want to override the log_errors directive in php.ini, you can do
that with

ini_set('displa y_errors', 1);
<http://www.php.net/manual/en/ref.errorfunc.p hp#ini.display-errors>

or, maybe with (I never tested it)

ini_set('error_ log', NULL);
<http://www.php.net/manual/en/ref.errorfunc.p hp#ini.error-log>

--
If you're posting through Google read <http://cfaj.freeshell. org/google>
Feb 2 '06 #8
error_reporting is set to '1', this according to php.ini

Phil

Chung Leong wrote:
If error_reporting is set to 0 in php.ini, you won't see any E_PARSE
error message even if you do an error_reporting (E_ALL), as the error
would occur prior to the line being executed.


Feb 2 '06 #9

comp.lang.php wrote:
error_reporting is set to '1', this according to php.ini

Phil

Chung Leong wrote:
If error_reporting is set to 0 in php.ini, you won't see any E_PARSE
error message even if you do an error_reporting (E_ALL), as the error
would occur prior to the line being executed.


1 is E_ERROR, so you won't not be getting any E_PARSE message.

Feb 3 '06 #10

This thread has been closed and replies have been disabled. Please start a new discussion.

Similar topics

6
1785
by: greenflame | last post by:
I have been working for some time on a script that will show a matrix with the elements aligned on the right for sometime and finally got it to work. Then I did some patching up and ran the script and it showed a blank page and no error in the status bar. The script is rather long and I call functions that do things that I may not need the functiosn for but they are there because I so that task so many times that I jsut made it into a...
9
1730
by: Matthias Kaeppler | last post by:
Hi, I'm using phpWebSite to build my website and I want it to be standard conforming. However, the CSS validator always outputs an error: "Please, validate your XML document first! The processing instruction target matching "" is not allowed." The offending line is: <?xml version="1.0" encoding="iso-8859-1"?>
0
1117
by: Hubert Hermanutz | last post by:
Hi, I will launch an HTML help file (*.chm) from my application about followed items: int intId=1020; string strFile=@"C:\MyHelp.chm"; System.Windows.Forms.Help.ShowHelp(this, strFile, System.Windows.Forms.HelpNavigator.Topic, intId.ToString());
4
2547
by: Pete H | last post by:
I would like to have my new C++ projects start out with two configurations, UnicodeDebug and UnicodeRelease, instead of the standard Debug and Release configurations that Visual Studio always creates. Is there a way to configure Visual Studio to do this Thanks in advance - Pete H
4
2249
by: Jonathan Wood | last post by:
Greetings, I'm new to ASP.NET and am trying to figure out how to popup a help window. I was able to get the following code to work: helpButton1.Attributes.Add("onclick", "window.open('http://www.softcircuits.com', null, 'height=250, width=250, status= no, resizable= no, scrollbars=no, toolbar=no, location=no, menubar=no');");
1
3174
by: Claes Wedin | last post by:
I have problems using DataGridViewImageColulmn: The Image does not show (only a red X is shown). I tried this: - Create New WindowsForms app - In the Form: Drag a DataGridView control to the form - Add 2 columns and chose DataGridViewImageColulmn for one of them - In the Properties of this column, select property Image - Select Local resource and hit button Import
2
1128
by: Kenichi666 | last post by:
I have a column "description" in a sql table. it contains 2000 characters. I would like to setup my gridview column "Description" to show the first 30 characters only. At the moment it shows all the characters. Is there and option for this in Edit Columns, under GridView Tasks???
1
2000
by: nubianqnn | last post by:
Hello All, I am stumped on a function to show/hide drop down elements based on a user's selection. If a user selects a second item from the first dropdown list, then I want to show a related dropdown with two options. If a user selects the second option from the second dropdown, then I want to show a data field. Somehow this is not working quite right. I am using Coldfusion to dynamically populate the dropdown. Any help will be appreciated.
14
1799
by: bobyjones | last post by:
I am making a JS scipt but it gets to the alert box and doesn't show anything in it here it is <html> <body> <script Language="JavaScript" text="text/JavaScript"> var Stick = "27"; var Coal = "78"; var Torch = "105"; var RedStone = "26";
0
9861
marktang
by: marktang | last post by:
ONU (Optical Network Unit) is one of the key components for providing high-speed Internet services. Its primary function is to act as an endpoint device located at the user's premises. However, people are often confused as to whether an ONU can Work As a Router. In this blog post, we’ll explore What is ONU, What Is Router, ONU & Router’s main usage, and What is the difference between ONU and Router. Let’s take a closer look ! Part I. Meaning of...
0
9699
by: Hystou | last post by:
Most computers default to English, but sometimes we require a different language, especially when relocating. Forgot to request a specific language before your computer shipped? No problem! You can effortlessly switch the default language on Windows 10 without reinstalling. I'll walk you through it. First, let's disable language synchronization. With a Microsoft account, language settings sync across devices. To prevent any complications,...
0
10924
Oralloy
by: Oralloy | last post by:
Hello folks, I am unable to find appropriate documentation on the type promotion of bit-fields when using the generalised comparison operator "<=>". The problem is that using the GNU compilers, it seems that the internal comparison operator "<=>" tries to promote arguments from unsigned to signed. This is as boiled down as I can make it. Here is my compilation command: g++-12 -std=c++20 -Wnarrowing bit_field.cpp Here is the code in...
0
10301
tracyyun
by: tracyyun | last post by:
Dear forum friends, With the development of smart home technology, a variety of wireless communication protocols have appeared on the market, such as Zigbee, Z-Wave, Wi-Fi, Bluetooth, etc. Each protocol has its own unique characteristics and advantages, but as a user who is planning to build a smart home system, I am a bit confused by the choice of these technologies. I'm particularly interested in Zigbee because I've heard it does some...
0
9444
agi2029
by: agi2029 | last post by:
Let's talk about the concept of autonomous AI software engineers and no-code agents. These AIs are designed to manage the entire lifecycle of a software development project—planning, coding, testing, and deployment—without human intervention. Imagine an AI that can take a project description, break it down, write the code, debug it, and then launch it, all on its own.... Now, this would greatly impact the work of software developers. The idea...
0
7023
by: conductexam | last post by:
I have .net C# application in which I am extracting data from word file and save it in database particularly. To store word all data as it is I am converting the whole word file firstly in HTML and then checking html paragraph one by one. At the time of converting from word file to html my equations which are in the word document file was convert into image. Globals.ThisAddIn.Application.ActiveDocument.Select();...
0
5685
by: TSSRALBI | last post by:
Hello I'm a network technician in training and I need your help. I am currently learning how to create and manage the different types of VPNs and I have a question about LAN-to-LAN VPNs. The last exercise I practiced was to create a LAN-to-LAN VPN between two Pfsense firewalls, by using IPSEC protocols. I succeeded, with both firewalls in the same network. But I'm wondering if it's possible to do the same thing, with 2 Pfsense firewalls...
0
5874
by: adsilva | last post by:
A Windows Forms form does not have the event Unload, like VB6. What one acts like?
1
4498
by: 6302768590 | last post by:
Hai team i want code for transfer the data from one system to another through IP address by using C# our system has to for every 5mins then we have to update the data what the data is updated we have to send another system

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.