473,372 Members | 1,016 Online
Bytes | Software Development & Data Engineering Community
Post Job

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 473,372 software developers and data experts.

Installing DBD::Oracle locally

Hi,

I am working on a system that I do not have root access on.. Therefore I am installing some modules that I need to my home directory.

So far when I installed the DBI class it worked fine. But when I go to install the DBD::Oracle module I get the error that

Expand|Select|Wrap|Line Numbers
  1.  perl Makefile.PL PREFIX=/homedirectory/PerlModules
  2. Can't locate DBI.pm in @INC (@INC contains: ../../perl5/5.8.8/aix-thread-multi /usr/opt/perl5/lib/5.8.8 ../../perl5/lib/site_perl/5.8.8/aix-thread-multi ../../perl5/lib/site_perl/5.8.8 p../../perl5/lib/site_perl .) at Makefile.PL line 21.
  3. BEGIN failed--compilation aborted at Makefile.PL line 21.
  4.  
Since the Oracle DBD module is dependant on the DBI class I assume I will someone need to add my home directory to the @INC list. Is this even possible?

Can someone give me a heads up on how to go about this if it is?

Thanks
Jul 27 '12 #1
12 3575
RonB
589 Expert Mod 512MB
Try adding this:
INSTALLPRIVLIB=/homedirectory/PerlModules
Jul 27 '12 #2
RonB
589 Expert Mod 512MB
Here's a link to more detailed info.
Installing Perl5 Modules Locally
Jul 27 '12 #3
Thanks for the link.
I tried following the suggestions in the Link you sent for the setenv PERL5LIB but that is for tch or csh and I'm using ksh. Would you happen to know the proper command?
Jul 29 '12 #4
RonB
589 Expert Mod 512MB
Setting the environment variable in the shell is not required, but you can do it if you want.

export PERL5LIB=/homedirectory/PerlModules
You'll need to specify all lib paths in the export statement separated by a colon.

Or, instead of setting the environment var, use the INSTALLPRIVLIB option/arg in the call to Makefile.PL as is also shown in that link that I posted.
Jul 29 '12 #5
So when I installed DBI I created the settings file such as what is provided in the link. perl Makefile.PL `cat LibPaths`
This is an AIX box. In case that helps.


In the file I followed the example's format
PREFIX=/usr/home/USERNAME/usr/local \
INSTALLPRIVLIB=/usr/home/USERNAME/usr/local/lib/perl5 \
INSTALLSCRIPT=/usr/home/USERNAME/usr/local/bin \
INSTALLSITELIB=/usr/home/USERNAME/usr/local/lib/perl5/site_perl \
INSTALLBIN=/usr/home/USERNAME/usr/local/bin \
INSTALLMAN1DIR=/usr/home/USERNAME/usr/local/lib/perl5/man \
INSTALLMAN3DIR=/usr/home/USERNAME/usr/local/lib/perl5/man/man3

Should I be replacing the \ between each path with a ; ?
I'm still having trouble seeing the DBD.pm file. And even when I export the Class path to the @inc statements the DBD.pm file still won't see the trigger.pm dependency that is located in the same Class folder.

Any suggestions?
Jul 30 '12 #6
I think I was creating my installation directories incorrectly... I am resinstalling all my local modules using perl Makefile.PL PREFIX=~/lib LIB=~/lib during setup. I will let you know how this works out when I go to install DBD::Oracle.
Jul 30 '12 #7
I'm still having the same issues. I have reinstalled everything in the local/lib directory yet when I go to install DBD::Oracle and point to the local/lib directory it is unable to find the DBI.pm dependency. :( Not sure what to do at this point.
Jul 30 '12 #8
numberwhun
3,509 Expert Mod 2GB
Just out of curiosity, have you tried doing a "make clean" and then rebuilding from there. That way it starts the build fresh instead of reusing its settings. I say this in case it already tried to read from the variable PERL5LIB the first time through, it won't try again unless you clean up the first attempt.

Its always a good idea to 'make clean' between build attempts.

Regards,

Jeff
Jul 30 '12 #9
I'll try to do a make clean and reinstall DBD::Oracle
Jul 31 '12 #10
When I try to do a make clean in the DBD::Oracle directory I get this message.

make: 1254-002 Cannot find a rule to create target clean from dependencies.
Jul 31 '12 #11
RonB
589 Expert Mod 512MB
You could start over from scratch by manually deleting the build directory and then untar the source and do a new build.
Jul 31 '12 #12
It looks like I got all the @inc and path issues figured out... Now I'm getting this when I run my DBD::Oracle makefile
Expand|Select|Wrap|Line Numbers
  1. perl Makefile.PL PREFIX=~/lib LIB=~/lib
  2. Segmentation fault(coredump)
  3.  
Completely stumped on this one...
Jul 31 '12 #13

Sign in to post your reply or Sign up for a free account.

Similar topics

1
by: rawii | last post by:
I am running on a Sun box and am trying to install the perl tools to connect to Oracle. When I try to install the DBD::Oracle module, I get the following. Please help.. What does is mean and...
0
by: Axel Dachtler | last post by:
Hi, I have downloaded both CPAN-moduls DBD-Oracle-1.14.tar and DBI-1.39.tar. But I fail in installing these moduls! The Perl Package Manager (PPM) returns this error message: no valid...
0
by: Envex Developments | last post by:
Hey guys, I have a need to install the DBD::Pg Perl module on many shared web servers, which do not have PostgreSQL installed. Then the DBD::Pg module will just connect to a remote PostgreSQL...
0
by: Envex Developments | last post by:
Hey guys, I have a need to install the DBD::Pg Perl module on many shared web servers, which do not have PostgreSQL installed. Then the DBD::Pg module will just connect to a remote PostgreSQL...
1
by: jrefran | last post by:
Hi everyone! I have problem on my DBD:Oracle installation from source code. Does anyone familiar with this kind of error. Please help! I'm completely new with this kind of work item. This is the...
1
by: kulkanuja | last post by:
I M installing oracle 9i on windows 2003 server and i am intalling on new Hp Proliant ML350 server(new Machine). its gives me an error message that. oracle/setup.exe is valid, but for the machine...
9
by: mdshafi01 | last post by:
Hello All, I have problem in installing DBD::ORACLE package. Please can any one have experience in installing DBD::ORACLE package. please give me some hints to install this DBD::ORACLE...
1
by: srikantvm | last post by:
Hi All, I am using perl, v5.8.8 built for MSWin32-x86-multi-thread and i tried installing the DBD-Oracle module but unable to install. Please find below the steps followed by me: 1) I first...
3
by: OracletoPerl | last post by:
hi to all can anyone help me out in getting DBD::Oracle for windows.. i am currently using oracle 9i and active perl state 5.8.8..
1
dlite922
by: dlite922 | last post by:
Hey guys. I don't think i've been into this forum for a while. I'm trying to install the oracle (ori8 ?) extension on php on a suse linux (v11?). Most of the (google results) articles just say...
1
by: CloudSolutions | last post by:
Introduction: For many beginners and individual users, requiring a credit card and email registration may pose a barrier when starting to use cloud servers. However, some cloud server providers now...
0
by: Faith0G | last post by:
I am starting a new it consulting business and it's been a while since I setup a new website. Is wordpress still the best web based software for hosting a 5 page website? The webpages will be...
0
isladogs
by: isladogs | last post by:
The next Access Europe User Group meeting will be on Wednesday 3 Apr 2024 starting at 18:00 UK time (6PM UTC+1) and finishing by 19:30 (7.30PM). In this session, we are pleased to welcome former...
0
by: Charles Arthur | last post by:
How do i turn on java script on a villaon, callus and itel keypad mobile phone
0
by: ryjfgjl | last post by:
If we have dozens or hundreds of excel to import into the database, if we use the excel import function provided by database editors such as navicat, it will be extremely tedious and time-consuming...
0
by: ryjfgjl | last post by:
In our work, we often receive Excel tables with data in the same format. If we want to analyze these data, it can be difficult to analyze them because the data is spread across multiple Excel files...
0
by: emmanuelkatto | last post by:
Hi All, I am Emmanuel katto from Uganda. I want to ask what challenges you've faced while migrating a website to cloud. Please let me know. Thanks! Emmanuel
1
by: Sonnysonu | last post by:
This is the data of csv file 1 2 3 1 2 3 1 2 3 1 2 3 2 3 2 3 3 the lengths should be different i have to store the data by column-wise with in the specific length. suppose the i have to...
0
by: Hystou | last post by:
There are some requirements for setting up RAID: 1. The motherboard and BIOS support RAID configuration. 2. The motherboard has 2 or more available SATA protocol SSD/HDD slots (including MSATA, M.2...

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.