469,348 Members | 1,693 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,348 developers. It's quick & easy.

How do I update PPM?

I was using PERL 5.6.1.638 with the standard PPM. I upgraded to 5.8.8.817. When I start PPM and query * it reports "Querying target 1 (ActivePerl 5.6.1.538). How do I upgrade PPM. I need to update my DBI and DBD packages.
Oct 29 '10 #1
2 2789
numberwhun
3,503 Expert Mod 2GB
If you installed the latest version, then I wonder if it is something to do with your path. Find out if, when it was installed, it installed to a different directory, other than where the original install was. If so, then it didn't overwrite/update it, it simply installed a second version.

Unfortunately, even on Windows I don't use Active State. I prefer Strawberry Perl as it is more like Unix based Perl and you interact with CPAN directly, instead of a third party package manager.
Nov 1 '10 #2
Thanks for your reply. I was able to solve my problem by removing the two packages instead of uninstalling. PPM still reports the old version, but it seems to be working with new packages for 5.8.8.817. Go figure.
Nov 5 '10 #3

Post your reply

Sign in to post your reply or Sign up for a free account.

Similar topics

7 posts views Thread by Dave | last post: by
8 posts views Thread by Lauren Quantrell | last post: by
27 posts views Thread by VK | last post: by
16 posts views Thread by Philip Boonzaaier | last post: by
5 posts views Thread by PAUL | last post: by
8 posts views Thread by Zorpiedoman | last post: by
5 posts views Thread by Stephen Plotnick | last post: by
1 post views Thread by CARIGAR | last post: by
reply views Thread by zhoujie | last post: by
1 post views Thread by Marylou17 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.