By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,373 Members | 1,984 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,373 IT Pros & Developers. It's quick & easy.

How to get around strawberry Perl "out of memory" error

P: 4
I'm using Strawberry Perl to run awstats and encountering an "out of memory" error. Is there a configuration I can change to boost memory? There is plenty available on the machine.
Aug 11 '10 #1
Share this Question
Share on Google+
4 Replies


Expert Mod 100+
P: 589
This is not a configuration issue with Perl. The problem is that the awstats script is doing something it shouldn't, i.e., is using the wrong method to accomplish some tasks.
Aug 11 '10 #2

P: 4
This led me to look at it as a strawberry Perl config issue.

FAQ-SET750 : AWSTATS RUN OUT OF MEMORY DURING UPDATE PROCESS WITH CYGWIN PERL
PROBLEM:
When I run the update process on a large log file with cygwin Perl, AWStats run out of memory but I am sure that I have enough memory to run AWStats according to the 'memory' column in benchmark chart available in AWStats documentation (benchmark page).
SOLUTION:
It might be a limit inside Cygwin Perl. Try to increase the Cygwin parameter heap_chunk_in_mb.
Aug 11 '10 #3

Expert Mod 100+
P: 589
I've never adjusted that parameter but it's most likely a build parameter, which mean that you'll probably need to recompile cygwin.

What version of cygwin and perl are you using?

How much memory do you have?

How big is the log file?
Aug 11 '10 #4

P: 4
I'm actually using Strawberry Perl but was wondering what the corresponding config would be for that. I have 8 Gigs of memory, but Strawberry is a 32 bit so 4 is available for it, but it aborts when only using a couple hundred meg.
Aug 11 '10 #5

Post your reply

Sign in to post your reply or Sign up for a free account.