By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,852 Members | 2,182 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,852 IT Pros & Developers. It's quick & easy.

strange problem connecting oracle db

P: 22
when i run perl script in the cmd prompt , it runs well and outputs results from db.
but when i run the same script on apache server internet explorer. i get an error as
-----
install_driver(Oracle) failed: Can't load 'C:/perl/lib/auto/DBD/Oracle/Oracle.dll' for module DBD::Oracle: load_file:The specified module could not be found at C:/perl/lib/DynaLoader.pm line 202.
at (eval 5) line 3
Compilation failed in require at (eval 5) line 3.
Perhaps a required shared library or dll isn't installed where expected
at D:/Profiles/CHJT87/My Documents/My Website/cgi/trials/connection.pl line 8
----------
isnt this strange ??? i dont understand , is it error of oracle or perl apache server??

if anyone have knowledge about this do let me know,
thanks for reading the mail.
Aug 3 '09 #1
Share this Question
Share on Google+
17 Replies


KevinADC
Expert 2.5K+
P: 4,059
It looks to me like the Oracle drivers perl needs were not installed properly. How did you install DBD::Oracle? Are you using activeperl or strawberryperl or something different? With activeperl you should first try using the PPM application that comes with it to install modules. If strawberry perl you can install it from the CPAN shell.
Aug 3 '09 #2

P: 22
thanks kevin,
i just installed activeperl and i looked in perl/lib DBD was already there
but still i tried to download it from cpan and just copy pasted folder in lib. how to use ppm application.i am new to perl.
Aug 3 '09 #3

KevinADC
Expert 2.5K+
P: 4,059
open the activeperl folder on your hard drive and click on documentation and read the instructions for PPM. You can also read them on the activestate website. You can't copy and past the driver code into the DBD folder, it needs to be installed.
Aug 4 '09 #4

P: 22
i just have perl folder and i tried doing
ppm install DBD-ORACLE. but it showed that package doesnt exits

this is the error
=======================
C:\>ppm install DBD-Oracle;
Downloading ActiveState Package Repository packlist...failed 500 Can't connect t
o ppm4.activestate.com:80 (Bad hostname 'ppm4.activestate.com')
ppm install failed: Can't find any package that provides DBD-Oracle;


========
on previous computer i setup , it s working well. ther i had activeperl folder then perl folder in that
here i just have perl folder..
Aug 4 '09 #5

KevinADC
Expert 2.5K+
P: 4,059
add more repositories to the PPM application. See the PPM documentation.

Here is three good repositories:

http://theoryx5.uwinnipeg.ca/ppms/
http://www.bribes.org/perl/ppm
http://trouchelle.com/ppm/
Aug 4 '09 #6

KevinADC
Expert 2.5K+
P: 4,059
@kanishka1213
If there is no activestate or activeperl folder and you are using activeperl, I don't know what to tell you. I have used activeperl for years and there was always a folder on the hard drive.
Aug 4 '09 #7

P: 22
i download this and installed it
ActivePerl-5.10.0.1005-MSWin32-x86-290470.msi

so on my computer it create a folder for perl this way
C:/perl/bin/perl.exe
Aug 4 '09 #8

P: 22
when i try to add the repositories u gave from ppm it shows me fail .:-(
Aug 4 '09 #9

P: 22
if u say i get a activeperl folder then can u please give me the link from you installled ? so that i can get a similar configuration.
thank you so much,
Aug 4 '09 #10

KevinADC
Expert 2.5K+
P: 4,059
There should be an activestate or activeperl folder where all of the activestate/perl documentation is stored. If for some reason there isn't, you can read all the documentation online at the activestate website. Here is a link to the PPM instructions for activeperl 5.10

http://docs.activestate.com/activepe...Perl-faq2.html
Aug 4 '09 #11

KevinADC
Expert 2.5K+
P: 4,059
@kanishka1213
I don't use activeperl anymore, I switched to strawberry perl when I got my new computer.

If you are using Windows click on the start button, then programs, then search for the activestate or activeperl folder, should be on the C drive but could be on other drives if you installed to a different drive.
Aug 4 '09 #12

P: 22
when i add this to the repository
http://www.bribes.org/perl/ppm/

it gives me error
downloading file failed 500 cannot connect to www.bribes.org:80
(Bad hostname :www.bribes.org)
Aug 4 '09 #13

KevinADC
Expert 2.5K+
P: 4,059
That could be a firewall or proxy server problem. Read the "PPM, Proxies and Firewalls" section of the PPM documentation.

http://docs.activestate.com/activepe...pm_and_proxies

If that is not the problem, I don't know.
Aug 4 '09 #14

numberwhun
Expert Mod 2.5K+
P: 3,503
@KevinADC
It would have to be some kind of firewall problem preventing you from getting out because I just went to the URL's that Kevin provided and they loaded just fine in my browser.

Regards,

Jeff
Aug 4 '09 #15

P: 22
the things work fine for me . the only thing is did was uninstalling active perl and deleting all files associated with it and installing it again. the thing i guess was some perl files were on this computer and i installed it again . :-). happy endings.
thankyou kevin and Jeff.
Aug 4 '09 #16

KevinADC
Expert 2.5K+
P: 4,059
@kanishka1213

Very good, that would have have been my next suggestion, check for more than one install of perl. If you have a modern computer strawberry perl seems to work good. The newest version even comes with DBI and the mysql drivers already included, which I am pretty sure activeperl doesn't, although that might not be a benefit for you.

But if you decide to try strawberry perl you have to uninstall activeperl first.
Aug 4 '09 #17

P: 22
Thanks for the suggestions
Aug 4 '09 #18

Post your reply

Sign in to post your reply or Sign up for a free account.