By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
437,692 Members | 1,998 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 437,692 IT Pros & Developers. It's quick & easy.

HTTPS URLs monitoring

P: 7
Hi,

On AIX, I have a script that checks URLs availability with the Lwp::UserAgent module.

It has been checking HTTPS URLs without any problem, but since the OpenSSL and OpenSSH versions has been updated, I have an error message saying that HTTPS is not supported.

I don't have the Crypt::SSLeay module or the IO::Socket::SSL module installed and it has always been working fine. I think that when Lwp::UserAgent had been installed, it had been able to determine where the SSL library necessary to perform HTTPS request were located...

I have tried to reinstall the Lwp::UserAgent, but it is still the same thing
Any idea?
Oct 9 '08 #1
Share this Question
Share on Google+
3 Replies


P: 7
Well, at least, can somebody help me with installing the Crypt::SSLeay module. I can the following message when I try to compile!

# make CC=gcc
gcc -c -I/opt/freeware/include/openssl -D_ALL_SOURCE -D_ANSI_C_SOURCE -D_POSIX_SOURCE -qmaxmem=16384 -qnoansialias -DUSE_NATIVE_DLOPEN -DNEED_PTHREAD_INIT -q32 -D_LARGE_FILES -qlonglong -O -DVERSION=\"0.57\" -DXS_VERSION=\"0.57\" "-I/usr/opt/perl5/lib/5.8.2/aix-thread-multi/CORE" SSLeay.c
gcc: unrecognized option '-qmaxmem=16384'
gcc: unrecognized option '-qnoansialias'
gcc: unrecognized option '-q32'
gcc: unrecognized option '-qlonglong'
gcc: error trying to exec 'cc1': execvp: No such file or directory
make: 1254-004 The error code from the last command is 1.

Stop.


GCC has been newly installed. I presume that everything is ok with it...
Thanks for you help!
Oct 10 '08 #2

numberwhun
Expert Mod 2.5K+
P: 3,503
First, why try to build the module(s) by hand when there is a fully capable installer built into whatever distribution you are using.

Either way, have you tried the make without the "CC=gcc"? I think the first thing you should do, if the "Makefile.pl" exists, is a "perl Makefile.pl". After that, just do a "make", and after that, if all is successful, a make install.

Regards,

Jeff
Oct 10 '08 #3

P: 7
The thing is that my server is behing a firewall with no access to the internet...

Is there a way that I can use CPAN to install my module and set the urllist parameter to a local directory where I would have already downloaded the necessary files? (If somebody could tell me which files are necessary...)

I know that I can use Mini::CPAN, but it requires that I install the module manually which requires other modules to be installed....

Thanks!
Oct 10 '08 #4

Post your reply

Sign in to post your reply or Sign up for a free account.