468,316 Members | 2,041 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 468,316 developers. It's quick & easy.

CPAN module compilation

2
Hi all,

I am trying to install IO::Tty module from CPAN on my Windows Machine which has Active Perl 5.8.8 Version running.
During the module installation, I get the compilation error.

Following is the error:
Expand|Select|Wrap|Line Numbers
  1. #################################################
  2. ERROR: cannot run the configured compiler 'cl'
  3. (see conf/compilerok.log). Suggestions:
  4. 1) The complier 'cl' is not in your PATH. Add it
  5.    to the PATH and try again. OR
  6. 2) The compiler isn't installed on your system. Install it. OR
  7. 3) You only have a different compiler installed (e.g. 'gcc').
  8.    Either fix the compiler config in the perl Config.pm
  9.    or install a perl that was built with the right compiler
  10.    (you could build perl yourself with the available compiler).
  11. ##################################################
I understand I am missing some compilers, but not sure how to go about this.
I am a novice and hence please help me with your inputs or pointers.

Thanks in advance

Regards,
BS
May 14 '08 #1
1 1436
KevinADC
4,059 Expert 2GB
You should be using the PPM application that comes with activeperl to install your modules. See the activestate/activeperl documentation for details about using PPM.
May 14 '08 #2

Post your reply

Sign in to post your reply or Sign up for a free account.

Similar topics

5 posts views Thread by Alex Gittens | last post: by
1 post views Thread by Ville Walveranta | last post: by
reply views Thread by blupp | last post: by
reply views Thread by simon | last post: by
numberwhun
1 post views Thread by numberwhun | last post: by
reply views Thread by NPC403 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.