By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
457,727 Members | 1,151 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 457,727 IT Pros & Developers. It's quick & easy.

Problem installing Image::Magick.

P: 55
I downloaded the sorce from CPAN(PerlMagick-6.32.tar.gz).
I followed the normal procedure to install perl module on unix platform,
i.e.
1) perl Makefile.PL
during the execution of this command i am getting error as:

Note (probably harmless): No library found for -lgvc
Writing Makefile for Image::Magick

2)make
during the execution of commands i am getting too many errors and warnings
but most are stating that the variables are undeclared
e;g:
`Image' undeclared (first use in this function)
`ExceptionInfo' undeclared (first use in this function)

Does this module installation required libraries support which we need to export externally??
Mar 5 '07 #1
Share this Question
Share on Google+
9 Replies


P: 55
problem continues..
I find out that this module needs library file libgvc.so
I tried to get this library file from rpm source but that version is not compactible with UBUNTU.
So that's why it's giving me error while installing rpm file

rpm file:
graphviz-2.8-8.el3.at.i386.rpm

linux version:
2.6.15-27-386

so could you please suggest me any site from which i can download the rpm
file compactible with my linux version.
Mar 5 '07 #2

P: 55
I am trying to install Image::Magick Module but when i am giving make
i am getting bunch of errors, if any body installed this module previously,
help me for it's installation.

Expand|Select|Wrap|Line Numbers
  1. make
  2. cc -c  -I/usr/include/ -I../ -I.. -I/usr/include/librsvg-2 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/gtk-2.0 -I/usr/include/graphviz -I/usr/include/freetype2 -I/usr/include/libxml2 -D_REENTRANT -D_GNU_SOURCE -DTHREADS_HAVE_PIDS -DDEBIAN -fno-strict-aliasing -pipe -I/usr/local/include-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -g -O2 -Wall -W -pthread -O2   -DVERSION=\"6.3.2\" -DXS_VERSION=\"6.3.2\" -fPIC "-I/usr/lib/perl/5.8/CORE"  -D_LARGE_FILES=1 -DHAVE_CONFIG_H Magick.c
  3. Magick.xs:213: warning: missing initializer
  4. Magick.xs:1123: warning: implicit declaration of function ‚SetImageProperty‚
  5. Magick.xs:1123: warning: implicit declaration of function ‚InterpretImageProperties‚
  6. Magick.xs:1413: error: void value not ignored as it ought to be
  7. Magick.xs:1413: warning: statement with no effect
  8. Magick.xs:1493: warning: implicit declaration of function ‚SetImageMask‚
  9. Magick.xs:1584: error: ‚struct _Image‚ has no member named ‚origin‚
  10. Magick.xs:1584: warning: passing argument 3 of ‚ParsePageGeometry‚ from incompatible pointer type
  11. Magick.xs:1656: error: void value not ignored as it ought to be
  12. Magick.xs:1656: warning: statement with no effect
  13. Magick.xs:1855: error: ‚struct _ImageInfo‚ has no member named ‚transparent_color‚
  14. Magick.xs:1855: warning: statement with no effect
  15. Magick.xs:1857: error: ‚struct _Image‚ has no member named ‚transparent_color‚
  16. Magick.xs:1857: warning: statement with no effect
  17. Magick.xs:1966: error: ‚struct _ImageInfo‚ has no member named ‚virtual_pixel_method‚
  18. Magick.xs:2817: error: ‚MagickLayerMethod‚ undeclared (first use in this function)
  19. Magick.xs:2817: error: (Each undeclared identifier is reported only once
  20. Magick.xs:2817: error: for each function it appears in.)
  21. Magick.xs:2817: error: syntax error before ‚method‚
  22. Magick.xs:2852: error: ‚method‚ undeclared (first use in this function)
  23. Magick.xs:2852: error: ‚CompareAnyLayer‚ undeclared (first use in this function)
  24. Magick.xs:2852: warning: statement with no effect
  25. Magick.xs:2863: error: ‚MagickLayersOptions‚ undeclared (first use in this function)
  26. Magick.xs:2864: error: incompatible type for argument 1 of ‚ParseMagickOption‚
  27. Magick.xs:2871: error: syntax error before ‚option‚
  28. Magick.xs:2886: warning: implicit declaration of function ‚CompareImageLayers‚
  29. Magick.xs:3586: error: ‚struct _Image‚ has no member named ‚mask‚
  30. Magick.xs:3586: warning: comparison of distinct pointer types lacks a cast
  31. Magick.xs:3588: error: ‚struct _Image‚ has no member named ‚mask‚
  32. Magick.xs:3588: warning: comparison of distinct pointer types lacks a cast
  33. Magick.xs:3590: error: ‚struct _Image‚ has no member named ‚mask‚
  34. Magick.xs:3590: warning: passing argument 2 of ‚Perl_newSViv‚ makes integer from pointer without a cast
  35. Magick.xs:3677: warning: implicit declaration of function ‚GetImageProperty‚
  36. Magick.xs:3677: warning: assignment makes pointer from integer without a cast
  37. Magick.xs:3931: warning: implicit declaration of function ‚GetStringInfoDatum‚
  38. Magick.xs:3931: warning: implicit declaration of function ‚GetStringInfoLength‚
  39. Magick.xs:3998: error: void value not ignored as it ought to be
  40. Magick.xs:3998: warning: statement with no effect
  41. Magick.c: In function ‚XS_Image__Magick_Histogram‚:
  42. Magick.c:4544: warning: unused variable ‚ref‚
  43. Magick.c:4539: warning: unused variable ‚ix‚
  44. Magick.c: In function ‚XS_Image__Magick_GetPixels‚:
  45. Magick.c:4659: warning: unused variable ‚ref‚
  46. Magick.c:4654: warning: unused variable ‚ix‚
  47. Magick.c: In function ‚XS_Image__Magick_ImageToBlob‚:
  48. Magick.c:4898: warning: unused variable ‚ref‚
  49. Magick.c:4893: warning: unused variable ‚ix‚
  50. Magick.xs: In function ‚XS_Image__Magick_Layers‚:
  51. Magick.xs:5065: error: ‚MagickLayerMethod‚ undeclared (first use in this function)
  52.  
  53. Magick.xs:6926: warning: implicit declaration of function ‚PaintOpaqueImageChannel‚
  54. Magick.xs:6934: warning: implicit declaration of function ‚AcquireQuantizeInfo‚
  55. Magick.xs:6934: warning: assignment makes pointer from integer without a cast
  56. Magick.xs:6952: error: ‚struct _Image‚ has no member named ‚transparent_color‚
  57. Magick.xs:6952: warning: passing argument 2 of ‚QueryColorDatabase‚ from incompatible pointer type
  58. Magick.xs:7139: error: ‚struct _Image‚ has no member named ‚interpolate‚
  59. Magick.xs:7140: error: syntax error before ‚argument_list‚
  60. Magick.xs:7257: error: ‚struct _Image‚ has no member named ‚black_point_compensation‚
  61. Magick.xs:7258: warning: statement with no effect
  62. Magick.xs:7277: warning: passing argument 3 of ‚ProfileImage‚ makes pointer from integer without a cast
  63. Magick.xs:7300: warning: passing argument 3 of ‚ProfileImage‚ makes pointer from integer without a cast
  64. Magick.xs:7361: warning: implicit declaration of function ‚OrderedPosterizeImageChannel‚
  65. Magick.xs:7539: error: ‚struct _Image‚ has no member named ‚interpolate‚
  66. Magick.xs:7540: error: syntax error before ‚argument_list‚
  67. Magick.xs:7819: warning: implicit declaration of function ‚ExtentImage‚
  68. Magick.xs:7819: warning: assignment makes pointer from integer without a cast
  69. Magick.xs:7907: warning: implicit declaration of function ‚AdaptiveSharpenImageChannel‚
  70. Magick.xs:7908: warning: assignment makes pointer from integer without a cast
  71. Magick.xs:8075: error: ‚struct _Image‚ has no member named ‚mask‚
  72. Magick.xs:8076: warning: statement with no effect
  73. Magick.xs:8077: error: ‚struct _Image‚ has no member named ‚mask‚
  74. Magick.xs:8077: warning: passing argument 1 of ‚NegateImage‚ from incompatible pointer type
  75. Magick.c: In function ‚XS_Image__Magick_Mosaic‚:
  76. Magick.c:8461: warning: unused variable ‚ref‚
  77. Magick.c:8456: warning: unused variable ‚ix‚
  78. Magick.c: In function ‚XS_Image__Magick_Ping‚:
  79. Magick.c:8544: warning: unused variable ‚ref‚
  80. Magick.c:8539: warning: unused variable ‚ix‚
  81. Magick.c: In function ‚XS_Image__Magick_Preview‚:
  82. Magick.c:8743: warning: unused variable ‚ref‚
  83. Magick.c:8738: warning: unused variable ‚ix‚
  84. Magick.c: In function ‚XS_Image__Magick_QueryColor‚:
  85. Magick.c:8836: warning: unused variable ‚ref‚
  86. Magick.xs:10094: error: ‚TypeMetric‚ has no member named ‚origin‚
  87. Magick.xs:10094: error: request for member ‚x‚ in something not a structure or union
  88. Magick.xs:10094: error: incompatible type for argument 2 of ‚Perl_newSVnv‚
  89. Magick.xs:10095: error: ‚TypeMetric‚ has no member named ‚origin‚
  90. Magick.xs:10095: error: request for member ‚y‚ in something not a structure or union
  91. Magick.xs:10095: error: incompatible type for argument 2 of ‚Perl_newSVnv‚
  92. Magick.c:9455: warning: unused variable ‚ref‚
  93. Magick.c:9450: warning: unused variable ‚ix‚
  94. Magick.c: In function ‚XS_Image__Magick_QueryFormat‚:
  95. Magick.c:9819: warning: unused variable ‚ref‚
  96. Magick.c:10519: warning: unused variable ‚ix‚
  97. Magick.c: In function ‚boot_Image__Magick‚:
  98. Magick.c:10618: warning: unused parameter ‚cv‚
  99. make: *** [Magick.o] Error 1
  100.  
the errors are more than shown above due to text limitation i made it
short.
Mar 9 '07 #3

P: 1
Hi, rahatekarabhijeet

I also meet this issue, did you solve the problem?
Could you share your experience for me?

Thank you very much in advance!!!!!!
Alvin
Mar 26 '07 #4

P: 3
Package is missing a file but you can't catch it unless you save your session to an output file like putty or something:

#make
gcc -c -I../ -I.. -I/usr/include/librsvg-2 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/gtk-2.0 -I/usr/include/graphviz -I/usr/include/freetype2 -I/usr/include/libxml2 -D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -pipe -Wdeclaration-after-statement -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm -g -O2 -Wall -W -pthread -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -DVERSION=\"6.3.2\" -DXS_VERSION=\"6.3.2\" -fPIC "-I/usr/lib/perl5/5.8.8/i386-linux-thread-multi/CORE" -D_LARGE_FILES=1 -DHAVE_CONFIG_H Magick.c
Magick.xs:64:31: error: magick/MagickCore.h: No such file or directory
Mar 27 '07 #5

P: 3
I downloaded the whole package from:

http://www.imagemagick.org/script/perl-magick.php

You have to compile the whole package first and then go into PerlMagick and compile that. You still get some errors but it finishes. I ran make test after it was done and got the following results:

Failed Test Stat Wstat Total Fail Failed List of Failed
-------------------------------------------------------------------------------
t/x/read.t 1 1 100.00% 1
Failed 1/24 test scripts, 95.83% okay. 1/333 subtests failed, 99.70% okay.
Mar 27 '07 #6

P: 3
At least 1 error so far while trying to use with Bugzilla R3C1 checksetup.pl script
Mar 27 '07 #7

KevinADC
Expert 2.5K+
P: 4,059
ImageMagick has it's own support forum, you will probably get better answers on that forum as this is really not a perl issue.
Mar 27 '07 #8

P: 1
If you are using Ubuntu, you can check your Synaptic Package Manager and search for imagemagick package and install
or
type

sudo apt-get install imagemagick

in shell.
May 1 '07 #9

P: 1
problem: compile error -lgvc in installing PerlMagick
solution:
1. install graphviz-2.16.1-1.fc6.i386.rpm (http://www.graphviz.org/Download_linux.php)
dependencies of graphviz: IPC-Run-0.80.tar.gz
2. install graphviz perl module (http://search.cpan.org/dist/GraphViz/)
3. recompile...

other alternative...
problem: PerlMagick error in compiling (http://search.cpan.org/~jcristy/PerlMagick-6.32/Magick.pm)
solution:
1. Install movable type Imagemagick(PerlMagick) http://wiki.movabletype.org/Installation_of_ImageMagick
2. yum install ImageMagick
yum install ImageMagick-perl
Feb 11 '08 #10

Post your reply

Sign in to post your reply or Sign up for a free account.