By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
459,276 Members | 1,418 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 459,276 IT Pros & Developers. It's quick & easy.

perl "Insecure dependency in `` while running setuid"

P: 3
When I ran a perl script named script.pl which have the the follwing line:
system("echo hostname = $HOSTNAME > /tmp/myinfo");
I have another shell script script.ksh which simply call script.pl within the script. the permission on script.ksh is: -rwsr-sr-x
WHen I ran script.ksh, I got the error message:
Insecure dependency in `` while running setuid at script.pl line 4.
If I do not use $HOSTNAME in script.pl, I have no trouble at all.
Could someone help me on this? Looks like setuid and $HOSTNAME variable cannot work together.

Thanks in advance.
Aug 29 '06 #1
Share this question for a faster answer!
Share on Google+

Post your reply

Sign in to post your reply or Sign up for a free account.