470,855 Members | 1,172 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 470,855 developers. It's quick & easy.

Perl 5.8.4 Installation Issues

Hey there-

We're attempting to get Perl 5.8.4 installed on our AIX machines, and
I've hit a wall. We're using mostly GNU utilities, (GCC, ld, ar,
etc.) running AIX 5.1 and 4.3.3. The configure works just fine, as
does the make minitest. The error I get is this:

make[1]: Entering directory `/usr/local/src/perl-5.8.4/ext/B'
make[1]: Leaving directory `/usr/local/src/perl-5.8.4/ext/B'
make[1]: Entering directory `/usr/local/src/perl-5.8.4/ext/B'
make[2]: Entering directory `/usr/local/src/perl-5.8.4/ext/B/C'
rm -f ../../../lib/auto/B/C/C.so
LD_RUN_PATH="" gcc -Wl,-bhalt:4 -Wl,-bM:SRE -Wl,-bI:../../../perl.exp
-Wl,-bE:C.exp -Wl,-bnoentry -lc -L/usr/local/lib C.o -o
.../../../lib/auto/B/C/C.so
/lib/crt0.o(.pr+0x88): : undefined reference to `.main'
collect2: ld returned 1 exit status
make[2]: *** [../../../lib/auto/B/C/C.so] Error 1
make[2]: Leaving directory `/usr/local/src/perl-5.8.4/ext/B/C'
make[1]: *** [subdirs] Error 2
make[1]: Leaving directory `/usr/local/src/perl-5.8.4/ext/B'
make: *** [lib/auto/B/B.so] Error 2
bash-2.05b#
It looks like it's an LD problem, but I have absolutely no idea what
could be wrong. If anyone has any ideas, please let me know!

Thanks!
-Steve
Jul 19 '05 #1
0 2443

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

42 posts views Thread by Fred Ma | last post: by
5 posts views Thread by Barbara Lindsey | last post: by
3 posts views Thread by Paul Mc Gee | last post: by
reply views Thread by Kirt Loki Dankmyer | last post: by
2 posts views Thread by =?Utf-8?B?R3JlZw==?= | last post: by
12 posts views Thread by disappearedng | last post: by
2 posts views Thread by theschaef | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.